After updating my cleveref package to the newest version, ver. 0.21, I suddenly get an "Undefined control sequence"-error, when the compress option is enabled.

Minimal NOT working example:




Minimal working example:




I can see that something has changed with compress in the newest version of cleveref, but I cannot figure, why my code does not compile. I have also tried with documentclass article, but I obtain the same error.

From log file:

Package: cleveref 2017/07/10 v0.21 Intelligent cross-referencing
LaTeX Info: Redefining \Cref on input line 904.
Package cleveref Info: compressing but not sorting references on input line 777
) (./test.aux)
\openout1 = `test.aux'.


! Undefined control sequence.
\cref@processgroup ...ref \cref@isrefsametypetrue 
                                              \@whilesw \if@cref@sametyp...
l.10 \cref{eqn}

The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.
  • 2
    Looks like a bug in the latest version of cleveref. Let's give Toby Cubitt (the creator and maintainer of the package) a day or two to issue an update with bug fixes.
    – Mico
    Feb 7 '18 at 21:09
  • 2
    @Mico That is assuming he already knows about the problem. So maybe the problems should also be reported properly.
    – moewe
    Feb 7 '18 at 21:12
  • 1
    @moewe - Toby is a member of this site. I trust he's set up to get email notifications of postings that contain the cleveref tag. :-)
    – Mico
    Feb 7 '18 at 21:15
  • 3
    I sent Toby a bug report yesterday, he is aware of the problem.
    – Simifilm
    Feb 8 '18 at 4:38
  • 1
    I bugfix is due soon.
    – Simifilm
    Feb 8 '18 at 17:55

I've posted a bug-fix pre-release (v0.21.1) to my web page which fixes this MWE. Note that this bug is in fact a different one to that which @Simifilm reported to me by email (also hopefully fixed in this pre-release). Please test on real documents and report back.

I very nearly missed this bug report. It would have be better if the OP had emailed the bug report and MWE directly to the email address given in the package and package docs. (A link to a SE question is fine, though sending me a full bug report and MWE by email saves me effort.) Although I am subscribed to the SE cleveref tag, and try to skim new questions for possible bugs, there's always a high chance I'll miss things posted only to stackexchange. Whereas, however long I take to reply, I will never miss something reported by email.

TL;DR: stackexchange is not a bug tracker. Post questions to SE; report bugs via the software's normal bug-reporting channels (as well as SE if you want). Plain old email for cleveref; bugzilla/github/trac/whatever for more sophisticated software.

  • I simply thought, I was doing something wrong. It didn't occur to me that it was a bug. I have tested the new version on my MWE along with a couple of other documents, which didn't compile with version 0.21. Everything seems to work perfect. Feb 9 '18 at 6:55
  • 2
    Thanks for the feedback on the bug-fix release. And no worries - I didn't intend to come down on you hard for failing to report the bug by email. Just that bug reports languishing on SE occurs frequently enough, that it seems worth educating anyone who reads the answer that it's best practice to also report bugs via the standard bug-reporting channels, once you suspect it's a bug. Bug reports are as valuable a part of free software development as code contributions. It's a shame for these to go to waste! Feb 10 '18 at 23:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.