2

After hours wasted trying to work with the Ubuntu repository version of TeXLive (tlmgr wasn't working), I installed the "native" version of TeXLive (2017, via "Quick Installer" from the official site) and tlmgr was now functional.

However, when I go ahead and install TexMaker from the Ubuntu repository, it rolls out its own (outdated) version of TeXLive. I've been trying to install from binaries on TeXMaker's site, but the site is down.

So then I tried installing TeXstudio, downloaded the appropriate binary (Ubuntu 16.04 64 bit QT5) and installed it via Software Center, but seemingly I'm getting things I never wanted. E.g. the "native" TeXLive's tlmgr was in /usr/local/texlive/2017/bin/x86_64-linux folder, after installing TeXstudio now it's "shadowed" by /usr/bin. It's also a version that is 2 years behind the current tlmgr from the official site.

How to install a TeX editor so that it doesn't roll out its own TexLive installation or tlmgr?

10
  • maybe creating a "fake package" (see tex.stackexchange.com/a/95373/36296) can help. Commented Feb 8, 2018 at 17:22
  • Your question is OS specific and I think that you had to use backports in Ubuntu (but I am not sure about that)... I think you have to add "linux" or simmilar tag to your question and ububtu in your title to have more chances to find an answer
    – koleygr
    Commented Feb 8, 2018 at 17:22
  • @koleygr Ubuntu was already among the tags, I've replaced it with linux. Thanks for mentioning. I'm not sure what you mean by 'backports'. I've used TeXLive's tl-installer, that isn't very OS specific apart from Linux in general.
    – TeXnophobe
    Commented Feb 8, 2018 at 17:25
  • @TeXnophobe, sorry, I didn't show the tag.. I suppose it was ok... google for "ubuntu 16.04 texlive backports" and I am sure that you will see what I mean. Backports is the way to get newer than official supported packages on ubuntu
    – koleygr
    Commented Feb 8, 2018 at 17:28
  • 1
    Exactly how did you install texstudio? If you install via the command line, you can give apt the option --no-install-recommends (look it up in the man page for at, not sure I spelled it correctly), then recommend additions will not be installed. Besides this just making and installing the equivs tl package will also be a good idea (I'm guessing that is what samcarters link describes, otherwise the page i always use can be found via a Google on "texlive vanilla Debian"
    – daleif
    Commented Feb 8, 2018 at 18:09

1 Answer 1

2

Thanks everyone for the input in the comments.

Here's what worked for me.

My system: Ubuntu 16.04 (Xenial) 64-bit

What I installed:

First I downloaded the "Quick Installer" from TeXLive and proceeded as recommended. I uncompressed the archive, ran the installer with sudo ./install-tl from the folder. It took a looong time to "quick install" all the 3500+ packages.

Then I installed TeXstudio with sudo apt-get install texstudio --no-install-recommends. (Thanks @daleif for mentioning the flag.)

After TeXstudio was installed, I launched the application. It prompted me with a warning about not having a TeX installation. I went to Options > Configure TeXstudio... and in Commands set the path to xelatex pointing to the TeXLive installation and then in Build set the Default compiler to xelatex (which is the compiler I'll mostly need, proceed similarly for other compilers of your choice).

Now the TeX installation seems to be OK. Feel free to point out potential pitfalls or anything.

The other suggested workarounds either failed at one point or are beyond my level of "expertise" and willingness to manage a system with hacks and tricks (I won't remember them by the time I need to change something).

1
  • 1
    The options configure should not be needed if you added the texlive path to the right configuration file. It usually goes into .profile (you need to log out and in again to activate it). If you added the path addition to bashrc, and you open texstudio from a menu, texstudio never runs bash and never sees the path change
    – daleif
    Commented Feb 9, 2018 at 19:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .