2

TL;DR In a parallel type setting environment using reledmac / reledpar, the footnote numbering is out of order.

I am currently creating a Latex document in a twoside class which contains a bilingual text: On the left side (the left page) there is always a latin text and on the right side (the right page) there is the german translation. For this I am using reledpar. I have stanzas (astanza) on the left side and the translation on the right side and I always let a headline / title preceed the actual stanza / translation.

Now the numbering count of the footnotes is out of order in the sense that first all footnotes for the stanzas and then the footnotes for the headlines are created. This created in a confusing numbering, as the first footnote in the first headline starts with something like "56" and the first footnote in the text below starts with "1".

Here is my MWE:

\documentclass[12pt,a4paper,twoside]{scrbook}
\usepackage[]{reledmac}
\usepackage[]{reledpar}

% Set stanza indents
\setstanzaindents{8,5,6}
\setcounter{stanzaindentsrepetition}{2}

% Print a line number for every second line on the left side
\firstlinenum{2}
\linenumincrement{2}

% Disable the line numbering on the right side
\firstlinenumR{1000000000}

% Print all footnotes at the end of the document
\usepackage{endnotes}
\let\footnote=\endnote

% Environment for Astanza with custom headlines
\newenvironment{AstanzaWithHeadline}[1]
{\begin{astanza}[\centering\textbf{\protect#1}]\setline{1}}
{\end{astanza}}

\begin{document}
\large
    \begin{pages}
    \begin{Leftside}
        \beginnumbering
            \begin{AstanzaWithHeadline}{This is a headline\footnote{First 
footnote in headline}}
                verse verse verse 1!&
                verse verse verse 2!\footnote{First footnote in text}&
                verse verse verse 3!&
            verse verse verse 4!\footnote{Second footnote in text}\&
        \end{AstanzaWithHeadline}
        \begin{AstanzaWithHeadline}{This is a headline\footnote{First footnote in headline}}
            verse verse verse 1!&
            verse verse verse 2!\footnote{First footnote in text}&
            verse verse verse 3!&
            verse verse verse 4!\footnote{Second footnote in text}\&
        \end{AstanzaWithHeadline}
    \endnumbering
\end{Leftside}
\begin{Rightside}
    \beginnumbering
        \pstart
            This is a translation paragraph. Still just a translation paragraph. There is nothing interesting in here, please move on.
        \pend
        \pstart
            This is a translation paragraph. Still just a translation paragraph. There is nothing interesting in here, please move on.
        \pend
    \endnumbering
\end{Rightside}
\end{pages}
\Pages

\theendnotes
\end{document}

This is how it looks like: Problematic numbering

Now I would like the numbering to start in the first headline with 1 and then just counting up. Any help appreciated!

  • I currently don’t have a solution, but: The problem does not appear if you disable the endnotes package and use standard footnotes. – Jasper Habicht Feb 8 '18 at 19:46
  • it is in my todolist for reledmac. I don't know when I will have time to solve this issue – Maïeul Feb 8 '18 at 23:54
  • cf github.com/maieul/ledmac/issues/616 – Maïeul Feb 9 '18 at 0:00
  • @Maïeul Thank you for creating an issue out of this. – Naturjoghurt Feb 9 '18 at 7:01
  • And @JasperHabicht thank you for the hint. The problem is that I am using a twoside setup where on the left page stanzas are synchronizeded to the translations on the right side. If I now have the footnotes (which can be rather long) on the bottom of each left page, half of the right page would be empty because of the synchronisation. But yes, this would generally solve the problem. Thanks! – Naturjoghurt Feb 9 '18 at 7:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.