1

After upgrading to MacOS High Sierra, the preview window in TeXShop no longer updates the PDF output after typesetting.

I edit the LaTeX file in a separate (terminal) window using vim (after 30 years it's built into my fingers, so it's easier) and then use TeXShop to run (pdf)latex and display the result. Until I upgraded from Sierra to High Sierra it always worked fine: edit, click "typeset", and see the updated PDF in the preview window immediately. Now it just freezes after typesetting: the page previously visible doesn't update and no longer scrolls--it's just dead. The only workaround I've found is to kill the preview window and reopen it.

I'm running TeXShop 3.97. I get the same behavior for all LaTeX files (no no unusual packages, nothing fancy--even a single page with just text hangs up). This worked fine for many years until the High Sierra update.

  • Welcome to TeX.SX! I'll try tomorrow, if nobody comes along before. – egreg Feb 8 '18 at 21:33
  • 1
    Check to make sure you have the On Startup section of the Source Tab of TeXShop->Preferences set up for an External Editor. Also make sure the External Editor section of the Preview Tab of TeXshop->Preferences is set up for Automatic Preview Update. – Herb Schulz Feb 8 '18 at 21:49
  • Why use TeXShop to run LaTeX? That's something VIM could also do with ease (as well as opening a preview...) – Skillmon Feb 8 '18 at 22:03
  • Herb: Thanks for the reply, but that doesn't fix it. I already had both of these set as you suggest. – Scott Fulton Feb 9 '18 at 0:27
  • Skillmon: I got started with TeXShop years ago when I got my first Mac--it seemed the easiest way to run it, and has always worked just fine (until now). – Scott Fulton Feb 9 '18 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.