0

I want to print some source code with minted, and the characters ^^I^^I^^I appears on the beginning of each line. It is independent on the chosen language syntax.

It looks like so:

output

What can I do to get rid of it?

3
  • Welcome to TeX.SX! How are you compiling? If you are using XeTeX you may need the -8bit option. – TeXnician Feb 10 '18 at 9:28
  • Well, yes, I'm using XeTeX, and with this option it works. Thank you! – MrMid Feb 10 '18 at 9:31
  • @TeXnician, could you make it an answer so I can mark it as a solution? – MrMid Feb 10 '18 at 9:33
0

Although I'm sure this is a duplicate, I'm going to answer this.

Your problem with ^^I when compiling with XeLaTeX can be solved by using the command-line option -8bit.

3
  • Now I see why I haven't found it elsewhere. The ^^I is a tabulator, and my code was already indented a bit. – MrMid Feb 10 '18 at 9:42
  • If you try tex.stackexchange.com/search?q=code%3A%22-8bit%22 the duplicate appears near the top. – egreg Feb 10 '18 at 10:28
  • @egreg Thanks for the hint. I rarely use the site's search (mostly another search engine that does not output the result that fast). – TeXnician Feb 10 '18 at 10:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.