2

I am trying to edit my old CV with modernCV in Linux. Some missing styles and classes are not installed automatically -- so I now must try to do this manually.

Since the popular package source ctan.org is not complete (such as luatexbase.sty), I had to add the missing files from this source. After I moved the collection with its folder to the texlive directory ...

/usr/share/texlive/texmf-dist/tex/latex/luatexbase/luatexbase-loader.sty

... and updated the Latex database ...

sudo texhash

... I tried to create the PDF in Texmaker via method LuaLaTeX.
But then I got the fatal error, mentioned below:

! LuaTeX error ...ve/texmf-dist/tex/latex/luatexbase/luatexbase.loader.lua:53: attempt to index field 'loaders' (a nil value)

stack traceback:
...ve/texmf-dist/tex/latex/luatexbase/luatexbase.loader.lua:53: in main chunk
[C]: in function 'dofile'
[\directlua]:1: in main chunk.
l.89 dofile(path)}

The lua interpreter ran into a problem, so the
remainder of this lua chunk will be ignored.

EDIT: after installing texlive-full I got additional error messages (in red colour).

The first error (mentioned above) you can see on the bottom of appended screenshot:

new screenshot of the same old problem

  • 2
    if you have a current latex, do you need to load luatexbase at all? the core of luatexbase is loaded by default in lualatex since 2015 release. There have been a lot of changes to luatex, I would be very surprised if the old loader code would work or be needed – David Carlisle Feb 10 '18 at 20:39
  • you have tagged the question with miktex but the paths in your question suggest that you are using texlive not miktex? – David Carlisle Feb 10 '18 at 20:41
  • the sources for the current version of luatexbase-loader (which is just a stub that loads luatexbase) are in ctan at the address that you give but the package is pre-installed in texlive so you do not need to get it from ctan. The other site that you give links to versions from 2011, which is pre-history as far as luatex is concerned, you should delete those from your tex input path. – David Carlisle Feb 10 '18 at 20:46
  • In March 2015 I had texmaker working on Windows 7, and it used miktex. Today I am still trying to use texmaker on Linux Mint, depending on texlive. On Windows miktex automatically installed missing styles/classes/etc. So I tried to also use miktex on Linux. But the installer for i386 architecture is missing. – gloschtla Feb 11 '18 at 15:47
3

The ctan link that you give does have the document sources for luatexbase (and legacy stub packages such as luatexbase-loader) You could install from there (just run tex on the .ins file to generate the packages) however this should not be needed, as luatexbase is in texlive you should have it installed already or can be installed via tlmgr or your linux package manager if you use a linux system distribution of texlive.

That said, the core of the old luatexbase package is built in to current releases of lualatex, so it is rather rare for you to need to explicitly load it at all.

The other site you link to has some versions of these files from 2011, luatex has changed a lot since then, and the old code in those files is unlikely to work on current releases of luatex.

luatexbase-loader.sty is in texlive, it should be installed as

/usr/local/texlive/2017/texmf-dist/tex/luatex/luatexbase/luatexbase-loader.sty

however it does nothing but load luatexbase as all the functionality of the old sub-packages has been incorporated into luatexbase or latex itself. The entire file is

\ifx
  \ProvidesPackage\undefined\begingroup\def\ProvidesPackage
  #1#2[#3]{\endgroup\immediate\write-1{Package: #1 #3}}
\fi
\ProvidesPackage{luatexbase-loader}
[2015/10/04 v1.3
  luatexbase interface to LuaTeX (legacy subpackage)
]
\ifx\RequirePackage\undefined
  \input{luatexbase.sty}%
\else
  \RequirePackage{luatexbase}
\fi
  • I thank for your answer. Since it should all be in texlive, I installed it completely ( sudo apt-get install texlive-full ) and then ( ` && ` ) updated with sudo texhash . But the same error still occurs. I found luatexbase-loader.sty in a different directory: /usr/share/texlive/texmf-dist/tex/luatex/luatexbase/ – gloschtla Feb 11 '18 at 15:34
  • my luatexbase-loader.sty contains exactly the same code. It's from October 2015. – gloschtla Feb 11 '18 at 15:41
  • Why do I need to have troubles installing missing packages, if there can be an automated installer? Not everyone has studied informatics :D – gloschtla Feb 11 '18 at 15:49
  • that isn't a different directory it's the same as I suggested (relative to the texmf-dist root), you are using a linux packaged version (managed with apt-get) rather than the upstream texlive original version (managed with tlmgr) but that is the same here. As you have shown no code (and only an image of the error message summary) hard to give more help, but if your file has . You said that your luatexbase-loader.sty looks as above, but in your question you said you installed the one from math.sut.ac.th/lab/software/texlive/texmf-dist/tex/luatex/… which is completely different. – David Carlisle Feb 11 '18 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.