0

I basically want to add invisible blind text to my document. To print the rough layout and take some notes on what I want to write inside each of the missing paragraphs.

I tried:

\phantom{\blindtext}

This only reserves one (very long) line of text.

\vspace{10cm}

This does not behave like text. I could add a lot of small \vspace but maybe there is a better solution?

  • You could set the textcolor to white: \textcolor{white}{\blindtext}. – leandriis Feb 12 '18 at 13:43
  • Oh man... sometimes the answer is too obvious. Thank you – Alex bGoode Feb 12 '18 at 13:46
  • Welcome to TeX.SX! – Bobyandbob Feb 12 '18 at 13:52
  • 2
    There is also the package transparent ... – Jasper Habicht Feb 12 '18 at 19:46
0

You can use a minipage or a vbox inside the \phantom-macro to get the real size.

With the blindtext inside a minipage you may get problems at pagebreaks, but a \vbox should do the work.

Check this example:

\documentclass{scrartcl}
\usepackage{blindtext}
\begin{document}

%Wrong
\fbox{
\phantom{\blindtext}
}

%Problems on page breaks
\fbox{
\phantom{\begin{minipage}{\textwidth}\blindtext\end{minipage}}
}

% The solution?
\fbox{%
\phantom{\vbox{\blindtext}}%
}

\fbox{\phantom{\vbox{\blindtext}}}

\end{document}

The \fboxes are added to make the space visible. They are not part of the solution.


Based on the comment, I expect this is a MWE for the problem:

\documentclass[twocolumn,english]{scrartcl}
\usepackage{babel}
\usepackage{blindtext}

\begin{document}

pre1: \blindtext

pre2: \blindtext

% \phantom{\blindtext}% One long line
\phantom{\vbox{\blindtext}}%correct paragraph, but in one block.

after \blindtext

\end{document}

Maybe there is another solution, but I don't expect that it can be solved with \phantom. See also Phantom and line break

  • It seems like the behavior is still different from adding just text. If the vbox is 'big' it gets moved to a new column leaving additional white space that would not be there if I added just the blind text. – Alex bGoode Feb 12 '18 at 14:17
  • Yes, in my example are some additional spaces. Can you try \fbox{\phantom{\vbox{\blindtext}}} (in one line). I will modify my answer to remove this spaces. – knut Feb 12 '18 at 18:18
  • Sorry, my comment was worded poorly. I have a two column layout. Once the column is full the text continues at the next column. When I put the blind text into the vbox the whole text gets moved to the new column. This creates additional empty space (not white spaces) in the previous column. Thank you for your help – Alex bGoode Feb 13 '18 at 8:01
  • This sounds like a duplicate of tex.stackexchange.com/questions/16003/phantom-and-line-break – knut Feb 13 '18 at 13:36
0

Setting the text color to white achieved what I was trying to do.

As leandriis wrote in a comment:

\textcolor{white}{\blindtext}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.