2

Looking at trip.log from CTAN we have on line 6488 \csname\endcsname {->{ but when I run triptest on either miktex or texlive I get the output \csname\endcsname{->{ without the space. What is the reason for this discrepancy?

  • 1
    Welcome to TeX.SE! Which version of MikTeX or TeX Live are you using? (This looks a lot like the most recent bug in TeX, the one that was fixed in 2014.) – ShreevatsaR Feb 12 '18 at 23:40
  • That sure looks like it, I'm running miktex 2.9.3759 (3.1415926). I didn't think my installation was that old, time to upgrade I guess. – nadder Feb 13 '18 at 0:25
  • Ah ok great, posted as an answer because comments can disappear. Also curious why you're running the triptest (that was originally intended for alternative implementations of TeX to say they were the “same” program), but I imagine you have your reasons. :-) – ShreevatsaR Feb 13 '18 at 0:37
  • Well, for fun I decided to rewrite tex in C++ to see how long it would take. It took about 30 hours to write it and twice that to fix all the typos and bugs I made. Today it finally passed the triptest except for that missing space. So I tested it on miktex and texlive as well with the same error. Nice to know the reason for it. Thanks alot for your help. – nadder Feb 13 '18 at 1:00
  • 1
    Ok, you talked me into it, cleaned up a bit and uploaded to github.com/nadder/rstex. – nadder Feb 15 '18 at 13:40
6

You need to upgrade your distribution to one after 2014, i.e. one that has TeX version 3.14159265 (2014), rather than the previous one 3.14159265 (2008).

By running the most recent trip test with an older TeX, you have hit upon the only thing that changed between those versions: in the years 2008–2013, there was only one bug reported in TeX, which was fixed in 2014. For details see:

Anyway, as you're running an older distribution MiKTeX 2.9.3759 (3.1415926), the failure of the older TeX on the newer trip test merely shows (correctly) that the older TeX (from before 2014) does not satisfy the updated definition of TeX.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.