0

I need to use the predefined and created Latex project. When I run the project in Texmaker I got the warning Citation on page 1 undefined for the new reference that I added and the reference is not added. But when I run this project on Sharelatex the new reference is added.

I change based on this page the bib(la)tex command line property to:

bibtex build/% -include-directory=build

What is the problem and how can I solve it?

7
  • Did you run the normal cycle: $(pdf)latex -> bibtex -> (pdf)latex (twice)`?
    – Bernard
    Feb 13 '18 at 1:17
  • 4
    Recommendation: don't use a separate build directory. Just use a working directory. It seems tidier, but it just isn't worth it.
    – cfr
    Feb 13 '18 at 2:21
  • @ Bernard Yes. I did. Feb 13 '18 at 3:27
  • @ cfr could you explain more I did not understand your suggestion. Feb 13 '18 at 3:28
  • I think cfr is suggesting to use (only) bibatex % and to make sure that 'Use a "build" subdirectory for output files' is turned off/unchecked (it is the checkmark just above the first separator on the TeXmaker commands pane).
    – moewe
    Feb 13 '18 at 8:18
2

I change my setting and it works. This is my new setting

1
  • 2
    I would like to know which setting did you change in order to make it work. I have the same problem but my 'Use a "build" subdirectory for output files' is already unchecked so I don't think that is the key. Jan 10 '20 at 9:35
0

I get citation undefined in Texmaker too. And For answer to Sean Yun-Shiuan (which asking the setting that user34* changed)

That is what i did :

Open setting -> go to compile fast - > choose the good one which look bib file too -> rename the file if needed (bibtex-file.bib)

Like this gif : (sorry is in french --') enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.