0

I created my first minimal working example for this Problem, I'm kinda proud! Hopefully it's correct. (I had to use so many "blindocuments" to get a TOC with more than one page)

I have a problem with the geometry package. I use "twoside" for defining margins for printing. I chose extra obvious margins for this example.

If you uncomment the 3 lines in my code (and delete the geometry-stuff) latex has no hiccups and always keeps the margins correct for the whole document. If I use geometry (which I really want, as I don't want to be stuck with a4paper-margins, but want to increase the used space on each side) Latex has a Hiccup at the List of figures. (With Hiccup I mean, Latex has the same margins on the 2 following pages, which means from this point on alle the margins are on the wrong side)

In my real document the problem starts even earlier, with my TOC starting on a left page with margins from a right page and the List of Tables suddenly on the correct side... (left page with left margins)?

I would be grateful for either a hint on how to fix the geometry package behaviour. Or another method to increase the usable space of a page (mostly on the bottom, I really dislike, that there is so much white).

\documentclass[twoside, openany]{scrreprt} 
\usepackage{blindtext}
\usepackage{geometry}

%% Following line mixes up left/right Page at List of Tables
\geometry{twoside,bindingoffset=4cm, top=2.75cm,bottom=2.75cm,inner=3cm,outer=3cm}

%% Following 3 lines never mix up left/right pages, but I cannot increase the size of the page (if I don't do it, my Thesis will look too long)
%\setlength{\oddsidemargin}{2cm} %% Außenränder
%\setlength{\evensidemargin}{-2cm} %% Innenränder
%\setlength{\topmargin}{-2cm}

\begin{document}    

\blindtext % This is supposed to be my abstract which HAS to appear before TOC

\pagenumbering{Roman} 
    \tableofcontents
    \listoffigures 
    \listoftables  % Here is where the error happens!

\pagenumbering{arabic}
\blinddocument
\Blinddocument
\Blinddocument
\Blinddocument
\blinddocument
\Blinddocument
\Blinddocument
\blinddocument
\Blinddocument
\Blinddocument
\Blinddocument
\Blinddocument
\Blinddocument
\Blinddocument
\blinddocument
\Blinddocument
\end{document}

Just wanna say: I already noticed that the list of tables has an Arabic page number, even though it should have an roman one... I fixed that in my real document already by using following code just before the list of tables:

\pagenumbering{Roman} 
\setcounter{page}{7} %% corresponds to the length of TOC and LOF
  • you are specifying margins relative to the default US letter size. Are you printing on A4 or on US Letter? – David Carlisle Feb 14 '18 at 14:51
  • It's A4. In my real document I have [ngerman] included before the scrreprt, I thought that would make the paper a4? – Bieri Feb 14 '18 at 14:55
  • actually you may be OK I hadn't noticed that you were using scrreprt (but I'd use a4paper option anyway as needed for other classes) – David Carlisle Feb 14 '18 at 14:58
  • You have not said what is wrong with the output, your list of tables is empty so it is rather hard to check any margins??? – David Carlisle Feb 14 '18 at 14:59
  • I suspect that you are looking for \clearpage before the \pagenumbering{arabic} but hard to be sure. – David Carlisle Feb 14 '18 at 15:01
0

When you change the numbering system in the middle of a document (imho today not really needed and senseful) then you should in a twoside document add a \cleardoublepage before the \pagenumbering. Without it you can have two right pages after another as latex doesn't use the absolute page number to decide if a page is odd or even but the current page number.

\documentclass[twoside, openany]{scrreprt}
\usepackage{geometry}

\geometry{twoside,bindingoffset=4cm, top=2.75cm,bottom=2.75cm,inner=3cm,outer=3cm,showframe}


\begin{document}


\pagenumbering{Roman}
blb
\cleardoublepage %compare with \clearpage
\pagenumbering{arabic}
blb
\end{document}
  • Thanks! That works with my "real" document. Unfortunately it inserts two blank pages and messes everything up... (before that my TOC was on two pages, next to each other, not on the same page where you have to flip it) Any tipps for how to NOT insert blank pages? I hoped "openany" was not only affecting chapters, but TOC/LOF/LOT as well... – Bieri Feb 14 '18 at 15:13
  • @Bieri if you use twoside then you have to have odd numbers on the right hand side of each two page spread. Perhaps you would prefer a oneside layout. Otherwise when you force the page number back to 1 you need \cleardoublepage to force that page to be on the right. – David Carlisle Feb 14 '18 at 15:15
  • With "twoside" odd numbers have to be on the right. If your frontmatter has only an odd number of pages you can't avoid to insert a blank page when you start the main matter if you want two numbering systems (Roman and arabic). – Ulrike Fischer Feb 14 '18 at 15:17
  • (maybe) a stupid question: Can I add alternating margins for printing in any oneside layout? – Bieri Feb 14 '18 at 15:18
  • So there is NO way to start the TOC (which obviously is always Page 1) on the left side? – Bieri Feb 14 '18 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.