1

This question already has an answer here:

I am writing a paper on the advancement of Stömer-Verlet method using the Elsevier template. However, I have a challenge when trying to cite. Take for example, in mybib

@article{Hairer03,
    title   = "Geometric numerical integration illustrated by the St\"{o}rmer–Verlet method",
    journal = "Acta Numer.",
    volume  = "12",
    pages   = "399--450",
    year    = "2003",
    doi     = "doi: 10.1017/S0962492902000144",
    author  = "{E. Hairer, C. Lubich and G. Wanner}"}

If I type

title   = "Geometric numerical integration illustrated by the Stormer–Verlet method",

it will run but will not run if I type

title   = "Geometric numerical integration illustrated by the St\"{o}rmer–Verlet method",

In this case, what can I do?

marked as duplicate by Mico, Stefan Pinnow, Phelype Oleinik, Seamus, Bobyandbob Feb 15 '18 at 16:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you show us a full MWE? What is the "Elesevier template" you refer to? Do you get any errors or warnings? – moewe Feb 15 '18 at 12:02
  • 4
    Have you tried St{\"{o}}rmer? The entire non-ascii letter has to be in braces. – daleif Feb 15 '18 at 12:04
  • 2
    BTW: author = "{E. Hairer, C. Lubich and G. Wanner}" is wrong, it should be author = "E. Hairer and C. Lubich and G. Wanner" (no double braces and names separated with and, see tex.stackexchange.com/q/36396/35864) – moewe Feb 15 '18 at 12:05
  • 1
    @moewe or just remove the "..." , {...} is just fine for bibtex entries. – daleif Feb 15 '18 at 12:09
  • 1
    The please post a full minimal example including information about which bibtex style are being used. Otherwise we'll have to keep guessing. Testing on something as cloas as possible yto your real document is a lot easier. – daleif Feb 15 '18 at 12:35
1

There are several issues with your bib entry. How to typeset Störmer may not be the most severe one.

  • You use the unicode-encoded form of the "en-dash" glyph: between the words "Stormer" and "Verlet". Do use -- instead, unless you use a unicode-aware TeX engine (XeTeX or LuaTeX) to compile the document.

  • In order to keep BibTeX from lowercasing the names Störmer and Verlet in the title field, encase them in curly braces.

  • Abbreviating the journal's name to Acta Numer. seems quite unnecessary. Instead, do write Acta Numerica. If you feel ambitious, you could set up a string variable that encodes whether or not the journal name should be abbreviated. If your paper is intended for submission to an academic journal, the journal will likely have its own, "house" rules regarding journal name abbreviations. Don't make their job more difficult by providing possibly non-standard abbrevations.

  • Remove "doi: " from the doi field and make sure to use a bibliography style that knows how to handle the doi field. Aside: If you don't already do so, be sure to load the url package.

  • To separate the authors' names in the author field, use the keyword and, not commas.

  • I'd also use the authors' full given names in the author field, and leave it up to the bibliography style to determine whether full or abbreviated given names should be shown in the formatted bibliography.

  • Writing St{\"o}rmer instead of Störmer in the title field should not be necessary if you either employ a unicode-aware TeX engine or (in case you employ pdfLaTeX, which is not fully unicode-aware) load the inputenc package with the option utf8.

The fully modified bib entry should therefore look something like this:

@article{Hairer03,
  author       = "Ernst Hairer and Christian Lubich and Gerhard Wanner",
  title        = "Geometric numerical integration illustrated by the
                  {St{\"o}rmer--Verlet} method",
  journal      = "Acta Numerica",
  volume       = 12,
  pages        = "399--450",
  year         = 2003,
  doi          = "10.1017/S0962492902000144",
}

If you use a bibliography style which doesn't process the doi field, but if you somehow believe it's really necessary to show the DOI string, just change the field

  doi          = "10.1017/S0962492902000144",

to

  note          = "doi: \url{10.1017/S0962492902000144}",

The note field is always processed, by pretty much every bibliography style that's out there, somewhere. (You did remember to load the url package, right?)


A full MWE (minimum working example):

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@article{Hairer03,
  author       = "Ernst Hairer and Christian Lubich and Gerhard
                  Wanner",
  title        = "Geometric numerical integration illustrated by the
                  {St{\"o}rmer--Verlet} method",
  journal      = "Acta Numerica",
  volume       = 12,
  pages        = "399--450",
  year         = 2003,
  doi          = "10.1017/S0962492902000144",
}
\end{filecontents}

\documentclass{article}
\usepackage{natbib}
\bibliographystyle{plainnat} % any bib style that processes the 'doi' field
\usepackage{url} % to process the contents of the 'doi' field

\begin{document}
\nocite{*}
\bibliography{mybib}
\end{document}
  • @egreg - Good point. I'll edit the bullet point accordingly. – Mico Feb 15 '18 at 14:36
  • @ Mico, thank you very much. God bless you all for the answers. I was able to resolve it that same day I asked the question. Thanks all – Omojola Feb 28 '18 at 12:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.