5

I have problems installing TeXlive 2017 to my Ubuntu 16.04.3. First I downloaded the .zip from the TeXlive homepage, after I unpacked the .zip and created the folder \usr\local\texlive. Then I did sudo su followed by .\install-tl.

I tried like this 3 times and everytime he stops after some minutes or even after a hour with codes like

TLUtils::check_file: removing /tmp/bEv_0Yfd3b/9rZn1FT0Qg/cm-super.tar.xz, checksums differ:
TLUtils::check_file:   TL=c4b76b04fc3abbad9b6d611e8588bfabeb6453e5c7d0696daa7bd7236193991869a9f8d7fc498e78357b8fb304f947db3ea25977d1f381edf43c14830acc769d, arg=8ad0ad8119cff2d8bc6e5eda4a214fed1c28f5c645f815c895c92055c622fc8c46bfec130d49e972e800128c57e7ace3e61c516915afb1284c0fdd5b5005f97b
TLPDB::_install_package: downloading did not succeed
Installation failed.
Rerunning the installer will try to restart the installation.
Or you can restart by running the installer with:
  install-tl --profile installation.profile [EXTRA-ARGS]
./install-tl: Writing log in current directory: /home/patrick/Downloads/install-tl-20180215/install-tl.log

What can I do?

closed as unclear what you're asking by Keks Dose, gusbrs, Stefan Pinnow, Bobyandbob, Phelype Oleinik Mar 8 '18 at 16:37

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Where exactly is it downloading from? You might be hitting an unstable repository. If you are the only user, then there is no need to install it as root. I normally create /opt/texlive and change it so I'm the owner, and then install there. – daleif Feb 16 '18 at 9:51
  • 1
    The checksums differ? Where did you download the file? As I understand, don't download the zip, but the tar.gz, which is much smaller, here: tug.org/texlive/acquire-netinstall.html – Keks Dose Feb 16 '18 at 9:51
  • I am downloading from here and I am sorry, surely I downloaded the .tar.gz and not the .zip. – user115202 Feb 16 '18 at 9:57
  • No you are not installing TL17 from www.tug.org, you are downloading the installer from tug.org. The TL data is spread around the world in mirrors, such that all the world does not download from tug.org. When the installer starts running it tells you which mirror repository you are installing from. I may be useful for us to know which mirror it is using. – daleif Feb 16 '18 at 10:18
  • 1
    I 'm using the same system as yours and I also faced this issue. Though it may sound foolish, but I was successful in installing by re-trying the installation for at least 5 times. I think at the sixth attempt, I didn't get the typical checksums differ error. I'm still not sure this might work for you, but you could still try out. – Sushant Chaudhary Mar 15 '18 at 13:09