0

This question already has an answer here:

Here is my Latex file:

\documentclass[10pt, a4paper]{amsart}
\usepackage{amsmath, amssymb,amsthm}
\usepackage{lettrine}
\usepackage[Sonny]{fncychap}
\usepackage{url}
\usepackage[english]{babel}
\usepackage{amsmath, amssymb,amsthm}
\usepackage[all]{xy}
\usepackage{tabularx}\renewcommand {\theenumi}{\roman{enumi}}
\usepackage[applemac]{inputenc}
\usepackage{graphicx} 
\usepackage[dvipsnames]{xcolor}
\usepackage{geometry}
\usepackage{hyperref}
\usepackage{url}
\usepackage[applemac]{inputenc}
\usepackage{enumitem}


\begin{document}
This is my latex file. I want to cite \cite{stackexchange}.
\bibliography{biblio}
\bibliographystyle{alpha}
\newpage


\end{document}

Here is biblio.bib:

@misc{stackexchange,
  title = {{R}eal units of the cyclotomic number fields of an odd prime order},
  howpublished = "\url{https://math.stackexchange.com/questions/175063/real-units-of-the-cyclotomic-number-fields-of-an-odd-prime-order}",
    author={{S}tack Exchange user {M}att {E}}
}

As a result, the reference is printed out wrongly, with large spaces between each word. You can see the result on the following screenshot. enter image description here

Thanks for your help

marked as duplicate by campa, Phelype Oleinik, egreg bibtex Feb 16 '18 at 16:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    "... with large spaces between each word ..." Which words, please? All of them, or just some of them? Please advise. Posting a screenshot of the problematic output would also be helfpul. Two additional questions: (a) Which bibliography style do you use? (b) Do you load the url and/or hyperref package? – Mico Feb 16 '18 at 11:38
  • I edited my question. – Emmanuel Lecouturier Feb 16 '18 at 11:57
  • 1
    Please post a full minimal example and something more useful than what it is you have redacted. My guess is that there is something here that LaTeX does not know how to hyphenate, but not details .... – daleif Feb 16 '18 at 11:59
  • 3
    you are not allowing URLs to break over a line but you are telling latex to justify the bibliography so stretching the word space is its only option. You could tell latex to set the bibliography raggedright or allow URL to break over a line (eg with url package) but the details depend on code you have not shown. – David Carlisle Feb 16 '18 at 12:42
  • I edited my question. A minimal working example is given. – Emmanuel Lecouturier Feb 16 '18 at 15:29

Browse other questions tagged or ask your own question.