0

Though forward search works fine, something is going wrong with the inverse search. In YAP, the command line for inverse DVI search is set to be

C:\Users\user\Vim\vim80\gvim.exe -c ":RemoteOpen +%l %f"

If I execute :echo g:Tex_CompileRule_dvi, I get the output

latex -src-specials -interaction=nonstopmode $*

If I double click at a location in the generated dvi document, my current Gvim windows closes and another empty gvim window opens which has the following things written at the bottom:

/Users/username/Desktop/Vimtex [noperm]
:let g:Remote_Server = 1

Could someone help me in setting up inverse search?

EDIT: I have understood that the error is occuring when the filename %f has a whitespace. Could someone tell me how to allow whitespace containing filenames too?

  • Welcome to TeX.SX! The -src-special method is obsolete. Are you sure you want to use DVI files? – egreg Feb 16 '18 at 16:24
  • I am fine with using any of dvi or pdf. I just want to get forward and reverse search working. Could you point me in the right direction? – Manan Feb 16 '18 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.