3

I am writing a small paper and I have to use two types of citations throughout the text.

The first one is 1)"(AUTHOR,Year)" and the second one is 2)"Author(Year)", while at the same time I am using, in the bibliography, apa style, so that it prints "Last Name, Initials (year). Title. etc".

I managed to succesfuly use only one of the citations styles (1 or 2) AND the bibliography, but I can't manage to use all three. I saw some solutions but they only used either all capital citations and a given type of bibliography style or, the other way around, non-capital citations and a given type of bibliography style.

I am using Mendeley to write my .bib file, Windows 8.1 and TexMaker.

Thanks in advance!

MWE:

\documentclass[12pt,a4paper]{article}

\usepackage[backend=biber,natbib=true,style=apa,maxbibnames=99,maxalphanames=99]{biblatex}
\usepackage{tablefootnote}
\addbibresource{C:/Users/Andre/Documents/Bibtex/library.bib}

\begin{document}


This should be the first type of citation "(AUTHOR et al.,Year)" but what I get is:\\ \citep{Alsina2017} \\
and this should be the second type of citation "Author et al.(Year)" and I sucessfuly get this:\\
\citet{Alsina2017} .


\newpage


\printbibliography
\end{document}
  • 1
    Just to be clear, you want all parenthesized citations (using \parencite) to capitalize the author names? – Alan Munn Feb 19 '18 at 16:17
  • I think it actually makes no difference since I will only use these two types of citations. Thanks for the response! – André Padilha Feb 19 '18 at 18:04
4

With a reasonably recent biblatex the following works

\makeatletter
\renewcommand*{\mkbibnamefamily}[1]{%
  \ifdefstring{\blx@delimcontext}{parencite}
    {\textsc{#1}}
    {#1}}
\makeatother

This checks if we are in a \parencite and if so, prints the name in small caps. All other names are left as is.

  • Very nice. You might want to add this answer to this question too: biblatex: uppercase in \parencite, but not in \textcite. – Alan Munn Feb 19 '18 at 16:47
  • It works, buut, it cites all authors instead of using "et al." – André Padilha Feb 19 '18 at 18:14
  • @AndréPadilha The 'et al.' is normally controlled by the option maxcitenames, but that does not work withstyle=apa. The APA style has special rules about 'et al.' that style=apa implements to the letter. – moewe Feb 19 '18 at 18:19
  • Got it. And what would be a good style to achieve alphabetically ordered bibliography? – André Padilha Feb 19 '18 at 18:22
  • @AndréPadilha style=authoryear (maybe with \DeclareNameAlias{sortname}{family-given})? It depends on what exactly you want. But you really should only use style=apa if you must follow the APA style. For ABNT freaks (shudder) there is github.com/abntex/biblatex-abnt – moewe Feb 19 '18 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.