1

I have an issue with citation format. For some unknown reason I get question marks around the title in bibliography section. Here is an example:

[6] Thorsten Joachims. ?Text Categorization with Support Vector Machines: Lear-
ning with Many Relevant Features? In: Proceedings of the 10th European
Conference on Machine Learning. ECML’98. Chemnitz, Germany: Springer-
Verlag, 1998, s. 137–142. isbn: 3-540-64417-2, 978-3-540-64417-0. doi: 10 .

As you can see there is a question mark before the "Text" word and after the "Features". Here is the source of the citation:

@inproceedings{textCatSVMs,
    author = {Joachims, Thorsten},
    title = {Text Categorization with Support Vector Machines: Learning with Many Relevant Features},
    booktitle = {Proceedings of the 10th European Conference on Machine Learning},
    series = {ECML'98},
    year = {1998},
    isbn = {3-540-64417-2, 978-3-540-64417-0},
    location = {Chemnitz, Germany},
    pages = {137--142},
    numpages = {6},
    url = {https://doi.org/10.1007/BFb0026683},
    doi = {10.1007/BFb0026683},
    acmid = {3108868},
    publisher = {Springer-Verlag},
    address = {Berlin, Heidelberg},
}

I get this behavior for citations of type article and inproceedings. Book and online types do not exhibit this behavior.

These question marks are the only issue, citation references work flawlessly.

This is the biblatex configuration:

\usepackage[backend=biber,style=numeric,sorting=none]{biblatex}

When building the file I run pdflatex biber and pdflatex again. Here is the task I implemented in gradle build system:

task compileFully() {
    doLast {
        exec {
            commandLine "pdflatex ${mainFile}".split()
        }
        exec {
            commandLine "biber ${mainFile}".split()
        }
        exec {
            commandLine "pdflatex ${mainFile}".split()
        }
    }
}
  • 1
    Welcome to TeX.SX! We will very likely need more information to understand what is going on in your case. These entrytypes usually receive quote marks around the titles. Why their are turning into question marks is probably something beyond biblatex. So could you please provide a minimal working example with bibliography (MWEB) which illustrates the problem? – gusbrs Feb 19 '18 at 17:10
  • 1
    This means that csquotes doesn't speak your language (Czech? Slovakian?), see tex.stackexchange.com/q/166337/35864 – moewe Feb 19 '18 at 17:12
  • Mhhh, actually csquotes speaks both czech and slovak, so that can't be it. Of course there are more languages with 'š', which is all I'm currently basing my guesses on. What is your babel setting? Can you show us a full MWE. – moewe Feb 19 '18 at 17:22
  • Mhhh, but an up to date version of csquotes should be able to deal with Czech quotation marks. In a short test it worked for me. So if it doesn't work for you, something else must be going on. The easiest solution would be if you had an outdated version of csquotes, but it might be something else. Using ` \usepackage[style=english]{csquotes}` is really a bad workaround instead of a proper solution. – moewe Feb 19 '18 at 23:59

Browse other questions tagged or ask your own question.