1

I am almost certain that the following used to work just fine. However, it certainly doesn't work any more.

I have workshop materials (based on UK TUG's) which use wrappers to input a common file containing the material for slides, handouts and notes. ignorenonframetext is used to avoid having the workshop exercises appear in the slides.

Last year, I started supplementing the handouts by adding appendices. This worked great. This also worked in November. It does not, alas, work now.

MNWE:

\documentclass[ignorenonframetext]{beamer}

\begin{document}
\begin{frame}{some frame}
some frame
\end{frame}

\appendix

\section{appendix}
some stuff
\end{document}

I first get lots and lots of messages saying

Package hyperref Warning: Token not allowed in a PDF string (PDFDocEncoding):
(hyperref)                removing `\translate ' on input line 20.

This message is repeated numerous times, with exactly the same line number.

This is followed by numberous instances of the following message,

Package hyperref Warning: Token not allowed in a PDF string (PDFDocEncoding):
(hyperref)                removing `\translate ' on input line 21.

with, again, the same line number.

After a while removing \translate on lines 20 and 21, TeX gives up.

! TeX capacity exceeded, sorry [input stack size=5000].
<inserted text> 
                \<>-\translate 
l.21 

!  ==> Fatal error occurred, no output PDF file produced!

What has changed and what should be changing to avoid this problem?

I am compiling with pdfTeX. I get the same error with TeX, LuaTeX or XeTeX, however.

1

This was a bug introduced in beamer version 3.44. For the moment this bug is fixed in the development version of beamer (and probably in release versions >= 3.50?), see the related bug report at https://github.com/josephwright/beamer/issues/464

While using https://raw.githubusercontent.com/josephwright/beamer/master/base/beamerbasesection.sty the MWE compiles fine again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.