I have drawn a set of circles in GeoGebra. It looks like this: enter image description here

And I would like to draw the same picture in TikZ. Thus, I enter the coordinate of the centers, and draw using minimum width parameter. This is what I write:




    \tikzstyle{disk} = [draw, thick, circle,fill=none]
    \node (A) at (-4,1) [disk, minimum width=20] {};
    \node (B) at (2,0) [disk, minimum width=70] {};     
    \node (C) at (0,6) [disk, minimum width=40] {};
    \node (D) at (8,2) [disk, minimum width=20] {};
    \node (E) at (8,-6) [disk, minimum width=80] {};



and this is what I get: enter image description here

How can I match the coordinate system units with width?

If I use millimeters as the units, the circles grow, but still do not intersect:

enter image description here

  • Just add mm after the units. – user121799 Feb 20 '18 at 13:48
  • @marmot did not work. please see the second figure. – padawan Feb 20 '18 at 13:55
  • Sorry! My bad! I missed the fact that there is a factor 2. If you look for instance at your circle around A, you see it has radius 2 (in whatever units), corresponding to diameter (or minimum width) 4. If these units are cm, which TikZ implicitly assumes if you put no units at the coordinates, this means you need to use 40 mm for this circle, and multiply all other minimun widths by 2 and add mm. – user121799 Feb 20 '18 at 14:07
  • Actually, I got what I wanted by fixing x=1cm, y=1cm and using \draw (0,0) circle (2cm) instead of \node command. – padawan Feb 20 '18 at 14:23
  • Typically any options must be given units (default is pt). Only (x,y) coordinates use the scale factors (default=1cm). – John Kormylo Feb 20 '18 at 15:19

I got what I wanted by fixing x=1cm, y=1cm and using \draw (0,0) circle (2cm) instead of \node command.

\begin{tikzpicture}[x=1cm, y=1cm, scale=0.5] % scale to prevent overflow
    \draw (-4,2) circle (2cm);
    \draw (2,0)  circle (7cm);      
    \draw (0,6)  circle (4cm);
    \draw (8,2)  circle (2cm);
    \draw (8,-6)  circle (8cm);
  • why scale? usex=0.5cm, y=0.5cm – Zarko Feb 20 '18 at 14:49
  • @Zarko I think you meant x=2, y=2. But that does not work as well, since the distances are not preserved. – padawan Feb 20 '18 at 14:52
  • x=1cm,y=1cm is actually the default, so you don't need those. – Torbjørn T. Feb 20 '18 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.