1

Good evening I am currently writing my thesis with latex and have faced a rather annoying problem. I cannot get my citation to work and couldn't solve this issue despite my efforts and following many threads. So I'd like you to keep in mind that I am not comfortable with the whole latex thing, so hopefully my issue is trivial... But it has given me headaches for month now ! Let me explain the details !

I have been writing on two different computers, and first implemented my citations on computer 1. It has always worked without a flow! But when I switched to computer 2 (which is my main computer), it worked for some time and eventually stopped working... It is still working on computer 1 (sadly not my main computer).

So I'm generating the .bib file using Zotero (better Bib LaTeX, generates unambiguous citation keys), writing with Texstudio 2.12.6, compiling with PdfLaTeX, default bibliography tool : BibTeX, document class: MastersDcotoralThesis.cls (v 1.5).

The code for citations has been given to me (so I must admit I don't fully understand it):

\usepackage[backend=bibtex,style=authoryear,natbib=true, maxbibnames=99,maxcitenames=2]{biblatex} 
\renewbibmacro*{name:andothers}{% 
    \ifboolexpr{
        test {\ifnumequal{\value{listcount}}{\value{liststop}}}
        and
        test \ifmorenames
    }
    {\ifnumgreater{\value{liststop}}{1}
        {\finalandcomma}
        {}%
        \andothersdelim\bibstring[\emph]{andothers}}
    {}}
\addbibresource{biblio.bib}

When I try to compile, my .bbl file gives me the "undefined control sequence" error for the commands : \datalist, \entry, \endentry

Here is an example of entry in my .bbl file (removing additional fields for clarity:

\begingroup
\makeatletter
\@ifundefined{ver@biblatex.sty}
  {\@latex@error
     {Missing 'biblatex' package}
     {The bibliography requires the 'biblatex' package.}
      \aftergroup\endinput}
  {}
\endgroup

\datalist[entry]{nty/global//global/global}
\preamble{%
\ifdefined\DeclarePrefChars\DeclarePrefChars{'’-}\else\fi
}

  \entry{KoshlandSevenPillarsLife2002}{article}{}
    \name{author}{1}{}{%
      {{hash=KDE}{%
         family={Koshland},
         familyi={K\bibinitperiod},
         given={Daniel\bibnamedelima E.},
         giveni={D\bibinitperiod\bibinitdelim E\bibinitperiod},
      }}%
    }
   \endentry

So as suggested by the.bbl file, the biblatex package seems to be missing. When I check MikteX (2.9.6515), it says Biblatex (3.10) is installed.

So my feeling is that there is some problem with MikteX/biblatex as my file compiles on my other computer (older version on MikteX) and on my friend's Mac but not on my same friend's PC.

Hopefully you can help me put the finger on the issue...

Thanks for your help (and hope my issue is not too dumb)

Edit: MWE (hope that will do) :

\documentclass{article}
\usepackage[backend=bibtex]{biblatex}
\addbibresource{biblio.bib}

\begin{document}
test \cite{LeungStepwisevisualizationmembrane2014}
\end{document}

Same "undefined control sequence (\datalist, \entry, \endentry)

Edit 2 :

I have tried using biber backend : \usepackage[backend=biber,style=authoryear-icomp,sortlocale=de_DE,natbib=true, url=false,doi=true,eprint=false]{biblatex} \addbibresource{biblio.bib}

Same error in .bbl file

closed as off-topic by moewe, Kurt, Phelype Oleinik, Andrew Swann, TeXnician Feb 24 '18 at 15:21

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What happens if you delete the .bbl file and recompile from scratch? Can you show us a complete, yet minimal example that reproduces your problem, an MWE/MWEB? – moewe Feb 20 '18 at 18:38
  • You might also want to consider using Biber instead of BibTeX. Use backend=biber instead of backend=bibtex and run Biber: tex.stackexchange.com/q/154751/35864 – moewe Feb 20 '18 at 18:53
  • 1
    Did you delete the .bbl file and recompile from scratch? – moewe Feb 21 '18 at 10:17
  • 1
    Hey everything is working smoothly ! Thanks again for your help, now i just need to edit some individual references to make them work and I'm good to go ! Cheers ! – Benjamin.B Feb 21 '18 at 14:33
  • 4
    I'm voting to close this question as off-topic because it was caused by remnants of an older TeX installation and a corrupted TeX distribution. A clean re-install solved the issue. – moewe Feb 24 '18 at 14:00

Browse other questions tagged or ask your own question.