2

I use TeX Live on Mac and I get my weekly updates through the TeX Live Utility. I am working on some slides for an upcoming talk. I am using the same Beamer templates and settings that I always use, so I was surprised to see that the page numbers that I always include at the bottom of my slides suddenly appeared in a different color. Here's an MWE:

\documentclass{beamer}
\useoutertheme{infolines}
\usecolortheme{beaver}
\title{Title}
\date{\today}
%\setbeamercolor{page number in head/foot}{fg=darkred!60!black}
\begin{document}
\begin{frame}
\end{frame}
\end{document}

MWE

As you can see in the bottom right corner of the slide the page number appears but its color looks off. Until recently it would look exactly the same color as the date appearing next to it.

By Googling around a bit I managed to figure out how to get this to look normal again using the line commented out in the code above:

\setbeamercolor{page number in head/foot}{fg=darkred!60!black}

By uncommenting this line I got back the desired behavior:

MWE working properly

So my question is not so much about how to fix this problem, but about why this is happening in the first place. Is this a bug that was introduced in a recent update, and if so will it be fixed? Is this a deliberate choice on the part of the developers (if so I can't imagine why)? Or am I doing something wrong or is something broken in my TeX setup?

I'd appreciate any insight on this. Thanks in advance!

  • Welcome to TeX.Stackexchange! – user36296 Feb 21 '18 at 11:59
  • Thanks! It's a great resource. (Long-time lurker and all that.) – Remco Feb 21 '18 at 12:08
3

This has already been fixed in the beamer development version (see this commit) and will be included in beamer version >= 3.50, which is about to be released.

As a temporary fix, place this updated file in your working directory https://raw.githubusercontent.com/josephwright/beamer/master/base/themes/color/beamercolorthemedefault.sty


As to why this happened: There had been a strange colour definition in the beamer default colour theme - which did not cause any problems as it was used nowhere in the beamer code.

Recently I introduced a new template (page number in head/foot) to make switching between different displays of page and frame numbers easier. Unfortunately this caused the previously unused colour to be used. Sorry for your problem!

  • This is what I was hoping to hear. Hopefully anyone having the same problem before the update is released will find this. – Remco Feb 21 '18 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.