0

(I have edited the post, with more information. It's my first post so sorry if I didn't explain the problem very well)

I have linux Mint 18.3 Cinnamon (64 bits). After the Miktex's last update (2.9.6615 version), when compiling my .tex (let's call it A.tex) file in Texmaker I don't get the updated PDF file. I made a new .tex file (B.tex for example) and then texmaker showed a window saying that the program doesn't find the .log file, without any error. I have tried to uninstall both miktex and texmaker and then install them again (firstly miktex and then texmaker), the problem remained.

Also I have installed Texlive, since a read a suggestion of one of you, and then texwork as editor. I tried again to compile the B.tex and it worked well, however, with my old A.tex it drops and error:

LaTeX Error: File `Classes/PhDThesisPSnPDF.cls' not found

It seems that the program doesn't find the place where the class of the A.tex is defined, but I don't know why. Before the last update of Miktex I hadn't had any problem and now I have it. That's why I guess it's because of the new version. I can't find the solution, hope there's somebody that could help me.

Thank you in advance!

  • Welcome to TeX.SX! – Bobyandbob Feb 22 '18 at 9:24
  • 1
    If the new miktex version introduced a bug you should make a bug report at the miktex issue tracker. – Ulrike Fischer Feb 22 '18 at 9:28
  • Good point, I'll do it! – Ana R. Feb 22 '18 at 9:29
  • 1
    I'm lead to believe that MikTeX on Linux is in a bit of an experimental state still (not sure if that is exactly right), so you might as well try a vanilla TeX live: tex.stackexchange.com/q/1092/35864 – moewe Feb 22 '18 at 10:49
  • 2
    Well you could have put a bit more effort in the bug report. E.g. which linux exactly, a minimal document that fails (and its name), if you can compile in the terminal, if the log-file is there, if you use options like --output-directory ... – Ulrike Fischer Feb 22 '18 at 12:10
1

Here I found the solution thanks to edocevoli from Miktex:

https://github.com/MiKTeX/miktex/issues/76

After the instructions given here, I compiled my A.tex file in Texmaker and it started a dialogue to install some more packages and that's it, it worked!

Thank you all

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.