1

I am having trouble with getting LuaLaTex with biber working in Hungarian. I have texlive-full install on an Ubuntu 16.04 and I did not have this issue with a previous install. I'm providing below an mwe, the output and warnings given by lualatex. How can I fix this?

The mwe:

\documentclass{article}
\usepackage{polyglossia}
\usepackage{csquotes}
\setmainlanguage{magyar}
\usepackage[defernumbers=true,sorting=none,backend=biber,maxnames=10,style=ieee]{biblatex}

\addbibresource{text.bib}

\begin{document}

Próba \cite{graphtheory,barabasi2016network,king2002home,linklater2000adaptive,moehlman1998feral,moehlman2002equids}

\printbibliography
\end{document}

The bib file:

@book{graphtheory,
  title={Graph theory},
  author={Bondy, John Adrian and Murty, Uppaluri Siva Ramachandra},
  year={2008},
  publisher={Springer}
}


@article{king2002home,
  title={Home range and habitat use of free-ranging Przewalski horses at Hustai National Park, Mongolia},
  author={King, SRB},
  journal={Applied Animal Behaviour Science},
  volume={78},
  number={2},
  pages={103--113},
  year={2002},
  publisher={Elsevier}
}

Output:

enter image description here

Errors:

Package csquotes Warning: No style for language 'magyar'.
(csquotes)                Using fallback style on input line 9.


Package biblatex Warning: Language 'magyar' not supported.
(biblatex)                Using fallback language 'english' on input line 9.

(/usr/share/texlive/texmf-dist/tex/latex/biblatex/lbx/english.lbx)
(./mwe_magyar.aux
Language magyar not found in language.dat.lua)
Language magyar not found in language.dat.lua (./mwe_magyar.bbl)(load luc: /hom
e/fbence/.texlive2017/texmf-var/luatex-cache/generic/fonts/otl/lmroman12-regula
r.luc)(load luc: /home/fbence/.texlive2017/texmf-var/luatex-cache/generic/fonts
/otl/lmroman12-bold.luc)

Package biblatex Warning: Bibliography string 'and' undefined
(biblatex)                at entry 'graphtheory' on input line 13.


Package biblatex Warning: Bibliography string 'jourvol' undefined
(biblatex)                at entry 'king2002home' on input line 13.


Package biblatex Warning: Bibliography string 'number' undefined
(biblatex)                at entry 'king2002home' on input line 13.


Package biblatex Warning: Bibliography string 'pages' undefined
(biblatex)                at entry 'king2002home' on input line 13.
  • 3
    This is simple. biblatex does not speak Hungarian, neither as magyar nor hungarian. If you want Hungarian support, you will have to write it yourself What is the most appropriate way to configure biblatex for use with an unsupported language?. The biblatex maintainers will be very happy to accept pull requests that implement Hungarian support at github.com/plk/biblatex/pulls, if you want to contribute what you come up with. – moewe Feb 23 '18 at 8:12
  • 3
    The Package biblatex Warning: Language 'magyar' not supported. warning is the giveaway. The question marks are caused by csquotes inability to speak Hungarian, Package csquotes Warning: No style for language 'magyar'., see quotation mark (quotation sign) xelatex + polyglossia + csquotes – moewe Feb 23 '18 at 8:14
  • That's very interesting, I'm pretty sure, that I had previously made a hungarian document with biblatex ... Is there a way to have a Hungarian document with citations in English as a quick fix? I will look at making a Hungarian localization for biblatex. – fbence Feb 23 '18 at 12:03
  • Add language=english to your biblatex loading options. – moewe Feb 23 '18 at 12:04
  • Mhh, language=english doesn't work. polyglossia and biblatex don't work together that well. Could you use babel? With babel biblatex automatically falls back to English and only warns about this. – moewe Feb 23 '18 at 12:13
3

Edit: Following this question Hungarian support has been implemented in version 3.12 of biblatex (https://github.com/plk/biblatex/issues/717, https://github.com/plk/biblatex/pull/780). So if you need support for Hungarian today, this should be as simple as making sure that you have an up to date version of biblatex.

Do note that the Hungarian localisation module is a bit special since the .lbx files are ill-equipped to deal with some features of non-Germanic languages. So double check the output carefully and read the warnings in the documentation and the .log file.

In general of course, bibatex can only implement localisations for a language if someone knowledgable in that language comes along and offers their help as was the case here.

The answer below is left for historical purposes.

At the moment biblatex has no support for Hungarian. This is what biblatex tries to tell you with

Package biblatex Warning: Language 'magyar' not supported.

If you use babel instead of polyglossia, biblatex will fall back to English, with polyglossia (for which localisation with biblatex is a bit shaky in general) you will get bold labels instead.

  • You should probably update your answer with today's developments :) – fbence Aug 15 '18 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.