0

I am trying to compile a standalone Feynman Diagram, but when I attempt to compile, it holds on compilation, and when the typesetting process is aborted on the GUI, the process is still running on my machine, and requires me to end the task. I am using MikTex with TexWorks on Windows 10, and have also tried useing Share-LaTex, but that simply times out.

\documentclass[tikz]{standalone}

\usepackage[compat=1.1.0]{tikz-feynman}
\begin{document}
\begin{figure}
\begin{tikzpicture}
\begin{feynman}
\vertex(q1);
\vertex[right=3cm of q1](q1o);
\vertex[below=0.5cm of q1](aq1);
\vertex[right=3cm of aq1](aq1o);
\vertex[right=1cm of aq1](g1);
\vertex[right=2cm of q1](g1o);
\vertex[below=1.5cm of g1](G);
\vertex[below=2cm of g1o](G1);
\vertex[below=1cm of G](G2);
\vertex[below=1cm of G1)(G3);
\vertex[below=5.5cm of aq1](aq2);
\vertex[below=0.5cm of aq2](q2);
\vertex[right=1cm of aq2](g2);
\vertex[right=2cm of q2](g2o);
\vertex[below=5.5cm of aq1o](aq2o);
\vertex[below=0.5cm of aq2o](q2o);
\diagram*{
(q1)--[fermion](q1o),
(aq1)--[fermion](aq1o),
(g1)--[gluon](G),
(g1o)--[gluon](G1),
(G)--[boson](G2),
(G1)--[boson](G3),
(q2)--[fermion](q2o),
(aq2)--[fermion](aq2o),
(g2)--[gluon](G2),
(g2o)--[gluon ](G3)
};
\end{feynman}
\end{tikzpicture}
\end{figure}
\end{document}

Edit: The Package is loaded correctly (top half of diagram compiles fine when all things dealing with q2, aq2, G2 &G3 are commented out, including their vertex declarations)

Last line of console output is

("C:\Program Files\MiKTeX 2.9\tex\generic\oberdiek\pdftexcmds.sty"))

And removing the last comma makes it so the process can be stopped by the abort typesetting

1

Wow, you put yourself in deep trouble...

I tried to run your code and it hanged, so I interrupted the compilation and TeX showed me this:

! Interruption.
\path ->\let \tikz@signal@path 
                               =\tikz@signal@path \pgfutil@ifnextchar [{\tik...

As far as I understand TeX, an instruction such as \let\problem\problem is a problem, so I did some research.

I found this post which shows essentially the same problem, but there is no actual solution there :\

Although it says that the \tikz@signal@path is a "quark" that shouldn't be executed. So I went on to find out where this quark was being executed.

A line-by-line comment-and-compile procedure pointed to the guilty line:

\vertex[below=1cm of G1)(G3);

Oh, would you look at that, an unmatched [ :)

It looks like TikZ sometimes can't handle unmatched brackets...

I took a long time to figure out the problem, so I thought it would be fair to take the same amount of time to write about it :)

TL;DR

There is an unmatched bracket here:

\vertex[below=1cm of G1)(G3);

just fix it:

\vertex[below=1cm of G1](G3);

and it will run fine:

enter image description here

  • Thank you so much, I figured it was something like that, I just have been staring at my screen so long that all the braces look the same :P – Silas K Grossberndt Feb 23 '18 at 14:09
  • @SilasKGrossberndt It happens :) – Phelype Oleinik Feb 23 '18 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.