13

After the latest TeX Live updates I keep getting these errors:

LaTeX Warning: You have requested, on input line 26, version
           `2018/02/21' of package expl3,
           but only version
           `2017/12/16 L3 programming layer (loader) '
           is available.


! Package xparse Error: Support package l3kernel too old.

Any help appreciated.

Solution (from Christian's comment): restore l3packages to the previous version.

8
  • 1
    Yes, just roll back the l3packages version to the latest version. It will work again after that.
    – user31729
    Feb 23 '18 at 15:49
  • @Christian: Tried, didn't worked. But it possible I didn't do it correctly, I am not really proficient with tlmgr &c. — would you mind to elaborate a liitle?
    – Marcel S.
    Feb 23 '18 at 15:50
  • 1
    What does tlmgr restore l3packages say? For example, it could output something like 46085 -- that will be the revision number to be restored, then use tlmgr restore l3packages 46085
    – user31729
    Feb 23 '18 at 15:51
  • 5
    Well, I got the same problem this morning and there was some thread in the TeX chat about this. Apparently only the l3packages bundle made it to TL from CTAN, but l3kernel is lagging behind. It should work in full after next update sequence tomorrow
    – user31729
    Feb 23 '18 at 15:54
  • 1
    Hello, I seem to have the very same problem with pdflatex (same error message). However, I have a fresh install of texlive only, i.e. I have no backed up version to switch back to. How can I install an older version of l3packages in this case?
    – absurd
    Feb 23 '18 at 19:54
10

I had the same issue, asked in chat, and was directed to this question. I have solved it on my machine so I'll just relate what I was told.

You need to revert the l3packages to the previous version. The command is

$ tlmgr restore l3packages

(probably prefix that command with sudo to run as root) If no revision number is specified, all available previous revisions are listed.

The response I got was

Do you really want to restore l3packages to revision 44864 (y/N):

After selecting y, I got

Restoring l3packages, 44864 from /usr/local/texlive/2016/tlpkg/backups/l3packages.r44864.tar.xz

And after that everything worked again.

According to comments by Christian and Nasser, not everybody's tlmgr restore is interactive like the one above. It may be the case that you just get the list of previously installed revisions. If so, choose the largest-numbered (i.e., most recent, not counting the current one), revision NUM, and type

$ tlmgr restore l3packages <NUM>
4
  • This fix is not working for me. I just updated tex live, and it broke lualatex. But when I do the restore l3packages command, It does not ask me for confirmation. It just puts a message saying Available backups for l3packages: 46085 (2018-02-23 21:38) and returns. lualatex is still broke. what is one to do now? screen shot !Mathematica graphics OK. It worked when I gave it the number, like this tlmgr restore l3packages 46085
    – Nasser
    Feb 24 '18 at 3:48
  • @Nasser: tlmgr restore l3packages 46085 is exactly what I wrote in a comment below the question about one day ago ;-)
    – user31729
    Feb 24 '18 at 13:57
  • @ChristianHupfer I see now your comment. But most folks read the accepted answer. Not go through comments. Therefore I think the above answer should be corrected to indicate the correct command to include the number. Otherwise, someone else could waste time trying to find why it is not working.
    – Nasser
    Feb 24 '18 at 15:45
  • @Nasser: the answer is community wiki, so everyone is free to edit and add additional details. Feb 24 '18 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.