5

My Windows 10 system has just started acting like and usual Windows system: every now and then, it suddenly stops by itself.

Unfortunately, it happened while I was updating TeX Live (2017).

Now, if I try to start the TeX Live GUI, I get immediately the error:

Problem with installation: cannot determine release!

If I launch tlmgr update --all in the command prompt, I get a series of invisible characters followed by:

at C:/texlive/2017/tlpkg/TeXLive/TLPOBJ.pm line 103, <TMP> line 1.

I've found this post: "TeX Live Manager" send an error with the message "Cannot determine release" but its answer doesn't help me, because I have the file release-texlive.txt in the directory C:\texlive\2017, containing:

TeX Live (http://tug.org/texlive) version 2017

This file is public domain.  It is read by install-tl --version,
tlmgr --version, and texconfig conf, and a final line appended with
the precise version number by tl-update-images during a build.

The following blank line helps avoid confusing output when
used directly from svn, so don't delete it.
  • Earlier today, someone posted with a similar question (not exactly the same). Seems that updates that should have been released by CTAN at the same time, were not released at the same time. In that case, the solution was to wait another day, until the updates catch up. I don't know if this pertains to your problem, but since you have a 21K reputation, I am sure that the problem is not your own. – user139954 Feb 23 '18 at 22:01
  • 2
    @RobtAll OK, I'll wait a couple of days and let you know if I still have my problem. I have 21K reputation because I'm TeX.SE addicted, but I'm more or less a beginner :):):) – CarLaTeX Feb 23 '18 at 22:05
  • The related question was easy to find: tex.stackexchange.com/questions/416862/… – user139954 Feb 23 '18 at 22:09
  • @RobtAll that's a very different problem. – Ulrike Fischer Feb 23 '18 at 22:11
  • @RobtAll it's a bit different, I get the error as soon as I click to start the GUI, it doesn't even give me the possibility to restore a package... :'( – CarLaTeX Feb 23 '18 at 22:13
1

I'm answering my own question just for the record.

In cases like mine, I highly recommend to send an email to tex-live@tug.org, see here for more info. (The mailbox is public, you can see the collection of prior postings to that list here. If it is the first time you write, wait a bit because your post is checked before publishing it.)

As for my problem, some files of mine got corrupted (e.g. my texlive.tlpdb in C:/texlive/2017/tlpkg contained only invalid chars, not normal text as usual).

Unfortunately, it didn't fix either running update-tlmgr-latest.exe nor running tlmgr recreate-tlpdb --platform=win32.

Eventually, since it should have been more complex to fix the problem (to find all the corrupted files) than to reinstall TeX Live, I reinstalled, and now it all works perfectly.

Before reinstallation, I run an "optimize and defragment" of my hard drive.

Thanks to Norbert (TeX Live team) and David for their help.

  • Thank you, but my problem is that if I want to reinstall, I'll need again to download more than 4GB, which I can't handle! – fardad.math Mar 9 at 10:30
  • 1
    @fardad.math Ask to tex-live@tug.org. That was the only solution for me. – CarLaTeX Mar 9 at 12:33
  • Thank you again. I accidentally solved my case, which was so dumb! I had had TexLive, and I've just installed it in a different location, without knowing that I already had it! By removing one, the other one worked well. – fardad.math Mar 10 at 0:29
  • 1
    @fardad.math I'm happy to know you solved your problem! – CarLaTeX Mar 10 at 5:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.