2

I have installed Latex 2016 on Debian Stretch (ruby 2.5 docker image) and I would like install packages from 2014 repository (ftp://tug.org/historic/systems/texlive/2014/tlnet-final), but when I tried install something, I see this error:

/usr/bin/tlmgr: cannot download: download did not succeed: 
ftp://tug.org/historic/systems/texlive/2014/tlnet-final/tlpkg/texlive.tlpdb.sha512

Problem is, that new tlmgr not support md5 file and require sha512 file, but in repository isn't sha512 file. How can I solve it? I tried set no-checksums=1 in config file, but it doesn't help. I'm not sure if config file have correct location also I'm not sure if no-checksums=1 should help.

I tried these locations for config file:

/usr/local/share/texmf/texmf.cnf
/root/texmf/texmf.cnf
/root/.texlive2016/texmf-config
/etc/texmf/texmf.cnf


kpsewhich -var-value=TEXMFSYSCONFIG
/etc/texmf

kpsewhich -var-value=TEXMFCONFIG
/root/.texlive2016/texmf-config

My steps:

apt-get update
apt-get install -y texlive-base texlive-bibtex-extra
tlmgr init-usertree
tlmgr option repository ftp://tug.org/historic/systems/texlive/2014/tlnet-final
tlmgr install babel-czech

Latex and tlmgr version:

pdfTeX 3.14159265-2.6-1.40.17 (TeX Live 2016/Debian)
tlmgr revision 41476 (2016-06-18 02:45:25 +0200)
tlmgr using installation: /usr/share/texlive
TeX Live (http://tug.org/texlive) version 2016

Thank you for any advice!

Edit: Question isn't about upgrading TL, but using archived repository from newer version TL. So I disagree, that it is duplicated question. Question is how to use archived repository 2014 from 2016 TL. In tlmgr is possible set archived repository.

  • 3
    We are in 2018, soon there will be TL 2018, so is there any need to get TL 2014 when having TL 2106 installed? – user31729 Feb 25 '18 at 8:32
  • 1
    In Debian Stretch is default TL 2016 (packages.debian.org/stretch/texlive-base), so therefore TL 2016. And I need repository from 2014, because I'm using it for auto-generating PDF documents, and it doesn't work correctly with new packages. It was developed in 2013-2014 years, but I need upgrade ruby only. But question is, how to use old repository with new TL? Because sha512 isn't in old repository. Maybe I should install somehow TL 2014. – rubydev Feb 25 '18 at 17:15
0

I think the answer to this turns out to be: in the historic folders, there seems to be an install-tl matching each version of Texlive, so just use that one.

For instance, if you want to install Texlive 2015, it is at:

If you browse those folders a bit, you will find the install-tl package here:

So you can do:

$ wget ftp://tug.org/historic/systems/texlive/2015/tlnet-final/install-tl-unx.tar.gz
...
$ tar xzvf install-tl-unx.tar.gz 
install-tl-20160405/
install-tl-20160405/readme-txt.dir/
install-tl-20160405/readme-txt.dir/README.SR
...
$ TEXLIVE_INSTALL_PREFIX=$(pwd)/texlive ./install-tl-20160405/install-tl --repository=ftp://tug.org/historic/systems/texlive/2015/tlnet-final --force-arch=i386-linux
Overriding platform to i386-linux
Loading ftp://tug.org/historic/systems/texlive/2015/tlnet-final/tlpkg/texlive.tlpdb
Installing TeX Live 2015 from: ftp://tug.org/historic/systems/texlive/2015/tlnet-final
Platform: i386-linux => 'GNU/Linux on Intel x86'       ### without force-arch: Platform: x86_64-linux => 'GNU/Linux on x86_64'
Distribution: net  (downloading)
...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.