0

I'm having problem which drives me crazy.

enter image description here

I'm trying to make odd/even pages with different margins using option [twoside] according to this answer. Numbers in red are page numbers. The problem is, that my 9th page does not have larger left margin than the right one (as it should have as odd page and right page when opened book). I tried adding blank pages, using \cleardoublepage... Nothing helped me. My 9th page still behaves like even page - left margin lesser than the right one.

The code:

\documentclass[11pt,a4paper,twoside]{report}
\usepackage[top=2.5cm,bottom=2cm]{geometry}
\usepackage[cp1250]{inputenc}
\usepackage[czech]{babel}
\usepackage{hyperref}
\usepackage{xcolor}
\usepackage{nameref}
\hypersetup{
colorlinks,
linkcolor={red!50!black},
citecolor={blue!50!black},
urlcolor={blue!80!black}
}

% Czech single quotes
% left (\clq command)
\DeclareTextCommand{\clq}{T1}{\leavevmode\char13\nobreak\hskip0pt}
% right (\crq command)
\DeclareTextCommand{\crq}{T1}{{\edef\@SF{\spacefactor\the\spacefactor}%
\nobreak\char96\@SF\relax}}
% \juv{} command
\DeclareRobustCommand\juv[1]{{\leavevmode\clq#1\crq}}
%%

\newcommand{\blankpage}{
\newpage
\thispagestyle{empty}
\mbox{}
\newpage
}

\bibliographystyle{plain}
\usepackage{graphicx}
\usepackage{float}
\graphicspath{ {File path} }
\title{TITLE}

\usepackage{url}

\begin{document}
\pagenumbering{gobble}% Remove page numbers (and reset to 1)
\begin{titlepage}
\centering
{\huge\bfseries NAME\par}
\vspace*{8cm}
{\Huge\bfseries TITLE\dots\par}
\vspace*{13cm}
{\huge\bfseries YEAR\par}
\end{titlepage}

\pagenumbering{gobble}% Remove page numbers (and reset to 1)
\begin{titlepage}
\vspace*{8cm}
\noindent   
{\bfseries THANKS TO ...\par}
\vspace*{13cm}
\noindent
\end{titlepage}

\chapter*{PREFACE}
\addcontentsline{toc}{chapter}{PREFACE}
PREFACE TEXT
\newpage

\blankpage
% CONTENT
\tableofcontents

\pagenumbering{gobble}
\chapter*{\centering \vspace*{8cm} \textbf{FIRST PART}}
\setcounter{chapter}{1}
\addcontentsline{toc}{chapter}{FIRST PART}

\blankpage

\pagenumbering{arabic}% Arabic page numbers (and reset to 1)
\section*{SECTION 1}
\addcontentsline{toc}{section}{SECTION 1} % This section still behaves like "left-side page" even though is numbered as 9
TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT     TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT     TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT TEXT

So how to make the first section after chapter behave "like a proper odd page" having larger left margin than right margin?

Thank you

EDIT: Better explanation

  • 1
    Double sided means that the odd page (right in opened book) will have a margin on it's right to add notes or whatever. So Do you really mean that you want to revert this functionality? [Optional you can answer at "What would that help?"] – koleygr Feb 25 '18 at 17:14
  • @koleygr Ok, I removed that tag. I meant "twoside" as for printing a book with different margins on left and right side. – svope Feb 25 '18 at 17:35
  • The problem was not the tag but your request. From this command: \documentclass[11pt,a4paper,twoside]{report} if you remove twoside option you may have a better result (for your needs)... But if you really want the opposite of your current margins please read again my previous commend more carefully. (Think of a printed book... Where would you like to add a note on a right page... left of a right page is the center of the book) – koleygr Feb 25 '18 at 17:39
  • @koleygr Ok, maybe I didn't ask the question in the right way. I want different margins for odd and even pages. According to this answer tex.stackexchange.com/a/122027/49879 , it's possible only with [twoside] parameter. But the problem is, that in my case, the 9th page is not printed as should be. I would expect that 9th page (the right when opened book) should have (as odd page) larger left margin than the right one which is not happening in my case. – svope Feb 25 '18 at 17:55
  • A typical cause of the margin problem might be, that the margins refer to the pagecounter. Every time you change the pagenumbering (i.e. from gobble to arabic), this resets to 1. About the purpose of the bigger outer margin: It is contrary to what @koleygr not only about notes (if even so). if it were even for even and odd, this would mean, that you would have double white space in the middle of the book. This looks not very well. Therefore usually half the margin is used for the inner side plus binding offset. This result in three even margins (left, center, right). – MaestroGlanz Feb 25 '18 at 18:25
1

Just in case anyone ever reads that question: This behaviour is caused by the fact, that the margins refer to the page counter. Everytime, the page numbering is changed, the page counter is reset.

i.e.

\pagenumbering{Roman}
%three pages full of text

\pagenumbering{arabic}
%plenty of other pages

The pagenumbering goes like

numbering:
A B C 1 2 3 4 ...
physical page:
1 2 3 4 5 6 7 ...

Now physical page 5 has page number 2. It should have oddsidemargin (because 5), but since the margin refers to the counter, evensidemargin is selected.

One workaround is to insert a blank page between roman pagenumbering and arabic pagenumbering (\newpage), another workaround is to invert oddsidemargin and evensidemargin:

\newdimen\tempdim
\tempdim=\oddsidemargin
\oddsidemargin=\evensidemargin
\evensidemargin=\tempdim

But the best solution is to use \cleardoublepage. This will print all floats (graphics and stuff) which are still in queue and might not have a suitable placement yet. If needed, the command inserts a page, so the next physical page is odd. Without this command, it might occur, that pictures appear in the wrong part (i.e. chapter) of the document.

  • 1
    \pagenumbering should only be used immediately after \cleardoublepage. – GuM Apr 1 '18 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.