1

I am continuing to get this error when compiling my TeX document:

Sorry, but "G:\Other Software\Developer Environments\MiKTeX\miktex\bin\x64\pdflatex.exe" did not succeed. The log file hopefully contains the information to get MiKTeX going again: C:/Users/User Name/AppData/Local/MiKTeX/2.9/miktex/log/pdflatex.log You may want to visit the MiKTeX project page, if you need help.

Oddly, it still seems to be producing a pdf. The log output is:

2018-02-26 21:36:49,287-1000 INFO  pdflatex - starting with command line: 

"G:\Other Software\Developer Environments\MiKTeX\miktex\bin\x64\pdflatex.exe" -synctex=1 -interaction=nonstopmode "ED Case Report - Jan 2018.tex"
2018-02-26 21:36:49,287-1000 INFO  pdflatex - allowing known shell commands
2018-02-26 21:36:49,287-1000 INFO  pdflatex - enabling input (output) from (to) processes
2018-02-26 21:36:49,302-1000 INFO  pdflatex - going to create file: pdflatex.fmt
2018-02-26 21:36:51,422-1000 INFO  pdflatex - installing package placeins triggered by tex\latex\placeins\placeins.sty
2018-02-26 21:36:51,422-1000 FATAL pdflatex - Administrative mode cannot be enabled (makes no sense) because this is not a shared MiKTeX setup.
2018-02-26 21:36:51,422-1000 FATAL pdflatex - Info: 
2018-02-26 21:36:51,422-1000 FATAL pdflatex - Source: Libraries\MiKTeX\Core\Session\config.cpp
2018-02-26 21:36:51,422-1000 FATAL pdflatex - Line: 1268
2018-02-26 21:36:51,422-1000 INFO  pdflatex - finishing with exit code 1
2018-02-26 21:37:07,321-1000 INFO  pdflatex - starting with command line: "G:\Other Software\Developer Environments\MiKTeX\miktex\bin\x64\pdflatex.exe" -synctex=1 -interaction=nonstopmode "ED Case Report - Jan 2018.tex"
2018-02-26 21:37:07,321-1000 INFO  pdflatex - allowing known shell commands
2018-02-26 21:37:07,321-1000 INFO  pdflatex - enabling input (output) from (to) processes
2018-02-26 21:37:07,405-1000 INFO  pdflatex - installing package placeins triggered by tex\latex\placeins\placeins.sty
2018-02-26 21:37:07,405-1000 FATAL pdflatex - Administrative mode cannot be enabled (makes no sense) because this is not a shared MiKTeX setup.
2018-02-26 21:37:07,405-1000 FATAL pdflatex - Info: 
2018-02-26 21:37:07,405-1000 FATAL pdflatex - Source: Libraries\MiKTeX\Core\Session\config.cpp
2018-02-26 21:37:07,405-1000 FATAL pdflatex - Line: 1268
2018-02-26 21:37:07,405-1000 INFO  pdflatex - finishing with exit code 1
2018-02-26 21:37:07,558-1000 INFO  pdflatex - starting with command line: "G:\Other Software\Developer Environments\MiKTeX\miktex\bin\x64\pdflatex.exe" -synctex=1 -interaction=nonstopmode "ED Case Report - Jan 2018.tex"
2018-02-26 21:37:07,558-1000 INFO  pdflatex - allowing known shell commands
2018-02-26 21:37:07,558-1000 INFO  pdflatex - enabling input (output) from (to) processes
2018-02-26 21:37:07,652-1000 INFO  pdflatex - installing package placeins triggered by tex\latex\placeins\placeins.sty
2018-02-26 21:37:07,652-1000 FATAL pdflatex - Administrative mode cannot be enabled (makes no sense) because this is not a shared MiKTeX setup.
2018-02-26 21:37:07,652-1000 FATAL pdflatex - Info: 
2018-02-26 21:37:07,652-1000 FATAL pdflatex - Source: Libraries\MiKTeX\Core\Session\config.cpp
2018-02-26 21:37:07,652-1000 FATAL pdflatex - Line: 1268
2018-02-26 21:37:07,653-1000 INFO  pdflatex - finishing with exit code 1

Does this have something to do with me not running it in Administrative mode? I'm not certain I know what that is or how to do it. It seems like my computer is trying to download a package it needs, but it can not get permission to do so. Is that correct? And if so, how can I address this issue and avoid the problemm in the future?

  • 1
    It sounds as if the on-the-fly is triggered in a mode suitable for multiuser installations while you have a single user installation. Check for updates with the update manager. If your system is up-to-date make a bug report in the miktex issue tracker on github. Side remark: better avoid spaces in file names. Even if it works nowadays in many cases it can cost you a lot time to handle the few cases where is fails. – Ulrike Fischer Feb 27 '18 at 8:10
  • Thank you, fixed by digging around in miktex console. Answer posted below! – Dylan Russell Feb 28 '18 at 2:24
3

For anyone that encounters this problem in the future - open MiKTeX Console -> settings -> set choose whether missing packages are to be installed on-the-fly: to Ask me.

It's slightly annoying because it will ask you if you would like to install each package individually but it resolved the Administrative mode error that I was receiving with the on-the-fly package installation.

  • 1
    Suggestion: In the future, if you install MikTeX again, use the portable version. Does not require Administrative install. Once working, make a zip archive that you can use to restore, if something goes wrong during updates. Can be duplicated on another computer via USB. – user139954 Feb 28 '18 at 4:57
  • Make a bug report. Give Christian the chance to remove the annoyance. – Ulrike Fischer Feb 28 '18 at 8:13
  • Will do! I’ll do it today. – Dylan Russell Feb 28 '18 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.