4

I have a scrartcl document (KOMA package). I want to change the DIV, making my textarea bigger.

I tried

\documentclass[DIV=12]{scrartcl}

But that does not change anything. When I try

\usepackage[DIV=12]{typearea}

I get

Option clash for package typearea

I do not understand that. How am I supposed to change the DIV in the KOMA class?

That what I load before \begin{document}

\documentclass[DIV=5]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage{natbib}
\usepackage{hyperref}
\usepackage{graphicx}
\usepackage[table,xcdraw]{xcolor}
\usepackage{booktabs,tabularx,ragged2e}
\usepackage{pifont}
\usepackage{lscape}
\usepackage{adjustbox}
\usepackage{enumitem}
\usepackage{longtable}
\usepackage{geometry}
\usepackage{caption}

\newcolumntype{P}[1]{>{\RaggedRight\arraybackslash}p{#1\textwidth}}
\newcolumntype{L}{>{\RaggedRight\arraybackslash}X}
\newlist{mylist}{itemize}{1}
\setlist[mylist]{label=\textbullet, nosep, wide, 
                 leftmargin=*,
                 before=\vspace{-0.50\baselineskip},
                 after =\vspace{-0.8\baselineskip}}


\begin{document}

2 Answers 2

7

Only if can not remove package geometry:

If you really want to use package geometry (e.g. to change the size of one margin) then add option usegeometry to the class options:

\documentclass[DIV=5,
  usegeometry% <- added
]{scrartcl}
\usepackage[showframe]{geometry}
\begin{document}
Text
\end{document}

enter image description here

If you can not remove package geometry because it is loaded by another package, then you can use \recalctypearea to overwrite the changes done by geometry:

\documentclass[DIV=5]{scrartcl}
\usepackage{geometry}
\recalctypearea
\begin{document}
Text
\end{document}
0
4

You're loading the geometry package, which overrides the settings made by the class, remove it.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .