2

I'm trying to suppress the comma in the postnotes but just in the short citations. In my MWE I get

Stratoydaki-White, «Patriarch Photios - A Christian Humanist», cit., p. 196.

instead of

Stratoydaki-White, «Patriarch Photios - A Christian Humanist», cit. p. 196.

I tried with the redefinition:

\renewcommand*{\postnotedelim}{\addspace}

But it obviously it affects every citation, not just the short ones.

How could I fix the problem?

MWE:

% !TEX TS-program = XeLaTeX
% !TEX encoding = UTF-8 Unicode

\begin{filecontents}{archivio.bib}


@article{Stu:Pat,
    Author = {Despina Stratoydaki-White},
    Date-Added = {2015-11-18 12:39:01 +0000},
    Date-Modified = {2015-11-18 12:40:01 +0000},
    Journal = {The Greek Orthodox Theological Review},
    Number = {2},
    Pages = {195-205},
    Title = {Patriarch Photios - A Christian Humanist},
    Volume = {25},
    Year = {1980}}


@article{Szi:Usu,
    Author = {Szidat, Joachim},
    Date-Added = {2017-09-25 13:16:22 +0000},
    Date-Modified = {2017-09-25 13:17:10 +0000},
    Journal = {Historia. Zeitschrift für Alte Geschichte},
    Pages = {487-508},
    Title = {Die Usurpation des Eugenius},
    Volume = {28},
    Year = {1979}}


\end{filecontents}

\documentclass[11pt, twoside]{book}   %openany
\usepackage{polyglossia}
\setmainlanguage[babelshorthands=true]{italian}
\setotherlanguages{latin, english, french}

%%% bibliografia
\usepackage[babel,italian=guillemets]{csquotes}

\usepackage[    style=verbose-trad2,            
            language=italian,
            useprefix=true,                 
            firstinits=true,    
            citepages=omit,                 
            backend=biber,  
        ]{biblatex} 

% \renewcommand*{\postnotedelim}{\addspace}

\addbibresource{archivio.bib}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\begin{document}


a\footcite[197-198]{Stu:Pat} \\

b\footcite[488]{Szi:Usu} \\

c\footcite[196]{Stu:Pat}


\end{document}

Many thanks!

  • Mhh, to me that looks more like you would say that the work was cited on p. 196 and not that this is an already cited work and you would like to refer to p. 196. I would not omit the comma here. – moewe Feb 28 '18 at 13:21
  • Me neither, but not my publisher unfortunately. – Teodoro Feb 28 '18 at 14:02
  • 2
    \DefineBibliographyStrings{italian}{opcit = {cit\adddot\nopunct}} seems to work. – moewe Feb 28 '18 at 14:05
2
\DefineBibliographyStrings{italian}{opcit = {cit\adddot\nopunct}}

works for the issue at hand and seems to be the least bad of several bad options.


A safer, but more tedious version, introduces a new check if we had an 'op. cit.' citation. That check needs to be done with a toggle, since at the time \postnotedelim is printed, the native checks to find out if a citation is 'op. cit.' are not available any more.

\documentclass[11pt, twoside]{book}
\usepackage{polyglossia}
\setmainlanguage[babelshorthands=true]{italian}
\usepackage{csquotes}
\usepackage[style=verbose-trad2, useprefix=true, giveninits=true, citepages=omit, backend=biber]{biblatex}

\addbibresource{biblatex-examples.bib}

\makeatletter
\newtoggle{cbx:opcit}

\renewbibmacro*{cite}{%
  \usebibmacro{cite:citepages}%
  \global\togglefalse{cbx:fullcite}%
  \global\togglefalse{cbx:loccit}%
  \global\togglefalse{cbx:opcit}%
  \bibhypertarget{cite\the\value{instcount}}{%
    \ifciteseen
      {\iffieldundef{shorthand}
         {\ifciteibid
            {\usebibmacro{cite:ibid}}
            {\ifthenelse{\ifciteidem\AND\NOT\boolean{cbx:noidem}}
               {\usebibmacro{cite:idem}}
               {\usebibmacro{cite:name}}%
             \usebibmacro{cite:title}}%
          \usebibmacro{cite:save}}
         {\usebibmacro{cite:shorthand}}}
      {\usebibmacro{cite:full}%
       \usebibmacro{cite:save}}}}

\renewbibmacro*{cite:title}{%
  \printtext[bibhyperlink]{%
    \printfield[citetitle]{labeltitle}%
    \setunit{\printdelim{nametitledelim}}%
    \bibstring[\mkibid]{opcit}}%
  \global\toggletrue{cbx:opcit}}

\renewcommand*{\postnotedelim}{\iftoggle{cbx:opcit}{\addspace}{\addcomma\space}}
\makeatother

\begin{document}
a\footcite[197-198]{sigfridsson}

b\footcite[488]{vizedom:related}

c\footcite[196]{sigfridsson}
\end{document}

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.