4

I use Zotero for my references and, at some point, a whole set of JSTOR ID's started appearing in my biber bibliography. I compile using pdflatex and biber.

JSTOR ID showing in bibliography

How can I get rid of these ugly JSTOR references? I assume it's to do with the eprinttype and eprint fields which Zotero appends to my entries.


foo.tex

\documentclass{article} 
\usepackage[backend=biber,doi=false,url=false,isbn=false,
    style=authoryear, maxcitenames=2,
    uniquename=false]{biblatex}
\AtEveryBibitem{% Get rid of the unwanted "note" field
  \clearfield{note}%
  \clearlist{language}%
}
\addbibresource{foo.bib}

\begin{document}
    \textcite{krugman_scale_1980-2} 
    \printbibliography
\end{document}


foo.bib

@article{krugman_scale_1980-2,
  eprinttype = {jstor},
  eprint = {1805774},
  title = {Scale {{Economies}}, {{Product Differentiation}}, and the {{Pattern}} of {{Trade}}},
  volume = {70},
  issn = {0002-8282},
  number = {5},
  journaltitle = {The American Economic Review},
  date = {1980},
  pages = {950--959},
  keywords = {dixit-stiglitz-ces},
  author = {Krugman, Paul},
  file = {/home/rob/Zotero/storage/VD5MZDJM/Krugman - 1980 - Scale Economies, Product Differentiation, and the .pdf}
}
2
  • 2
    If you don't want to use any other eprints, you can use eprint=false (that will also include arXiv, though). If you want to get rid of JSTOR specifically you can use Biber sourcemapping for that. – moewe Mar 1 '18 at 13:58
  • @moewe That did it. Thanks. If you'd like to answer the question, I'll accept it. – LondonRob Mar 1 '18 at 14:36
5

There are several ways to do this.

  1. The eprint=false option. This will disable all eprints, not just JSTOR. In particular this will also suppress references to the popular arXiv.
  2. Get rid of JSTOR eprints in \AtEveryBibitem

    \AtEveryBibitem{%
      \iffieldequalstr{eprinttype}{jstor}
        {\clearfield{eprint}}
        {}}
    
  3. Use Biber's sourcemapping to target JSTOR

    \DeclareSourcemap{
       \maps[datatype=bibtex]{
         \map{
           \step[fieldsource=eprinttype, match={jstor}, final]
           \step[fieldset=eprint, null]
         }
       }
     }
    
1
  • This is a brilliant answer. – LondonRob Mar 1 '18 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.