0

I'm using

\documentclass[twocolumn]{aastex62}

\usepackage[breaklinks,colorlinks,allcolors=blue]{hyperref}% hyperref works too
\urlstyle{same}  % (sf also works, for something more subtle than tt)
\usepackage{amsmath}    
\usepackage{mathrsfs}
\usepackage[]{units} % Provides \nicefrac

\usepackage{threeparttable}
\usepackage{multirow}

\renewcommand{\textfraction}{.10}
\renewcommand{\floatpagefraction}{0.9}
\setlength{\textfloatsep}{4pt plus 1.0pt minus 2.0pt}

\usepackage{ulem}

\usepackage{graphicx}       % Use pdf, png, jpg, or eps§ with pdflatex; use eps in DVI mode
\usepackage{dblfloatfix}

And floats that are 2 columns wide -- e.g. -

\begin{figure*}[th!]
\vspace*{1cm}
\includegraphics[width=.5\textwidth]{{{./Metallicity_z_12.0-brightRed}}} 
\includegraphics[width=.5\textwidth]{{{./Metallicity_z_9.0-brightRed}}} 
\caption{Locations of Pop III-bright galaxies. \label{fig:p3brightLocs}}
\end{figure*}

ALWAYS get their own page. How can I stop this? I can't

  • 2
    Hi, I work for the AAS Journals. Using the standard template file distributed with v6.2, I can only reproduce what you find if I include the \usepackage{dblfloatfix}. Commenting that out allows the text to flow around the figure just fine. Leaving it in causes the page breaks you describe. We do not support the dblfloatfix package. – Gus Mar 2 '18 at 2:41
  • btw, we already import hyperref with aastex62. You should use \hypersetup{breaklinks,colorlinks,allcolors=blue} instead – Gus Mar 2 '18 at 2:48
  • BTW, figure* does not support [h] or [h!] (although h! is actually htp). – John Kormylo Mar 2 '18 at 3:22
  • Note that \begin{figure*}[th!] is the same a \begin{figure*}[t!] so prevents the float appearing on a float page so greatly increases the chance of it going to the end of the document, also it is odd to have preamble commands setting parameters such as \renewcommand{\textfraction}{.10} if you use ! (which means ignore the parameter) or \renewcommand{\floatpagefraction}{0.9} if you use [ht] which means do not allow float pages – David Carlisle Mar 2 '18 at 17:11
  • Thank @Gus... perfect. I should have tried that. ... and thx John and David -- I was just trying everything (even tho I know h! isn't supposed to work) to try and get my text to flow! – earnric Mar 3 '18 at 4:34
1

As commented by @Gus, don't use

\usepackage{dblfloatfix}

with aastex62 ... It causes floats with figure* to always be placed on their own page.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.