1

I have a document with about 600 references I'm working on. I have biblatex setup in the following manner.

%   Bibliography stuff
%
    %   \usepackage{biblatex}
    \usepackage[style=authoryear,maxbibnames=99,maxcitenames=1,uniquelist=false,backend=biber,dashed=false,uniquename=false]{biblatex}
    \addbibresource{ThesisRefs.bib}

    % Make the citations have square brackets instead of round brackets
    \AtEveryCite{%
        \let\parentext=\parentexttrack%
        \let\bibopenparen=\bibopenbracket%
        \let\bibcloseparen=\bibclosebracket}

For nearly ALL of my references, I get something that looks like

Smith et al. 2018

Which is what I want. But, there are two or so references, that come in as a citation that includes the first name, looking like

Jeff Johnson et al. 2018

I've looked at my .bib file, and there is nothing different between the files. I even tried renamed 'Jeff' to 'Dave' in the bib file. And then the citations look like

'D. Johnson et al. 2018'

If I delete all my document text. Keep the SAME preamble. And write in just one or two lines of dummy text and \parencite{Johnson2018}, it comes in correctly. It only messes up when I have all many hundreds of references included with the full document.

I've tried making a MWE, but it only 'breaks' when I have the entire document.

How do I force ALL references to ONLY use the 'last' or 'family' name?

closed as off-topic by gusbrs, Sebastiano, Stefan Pinnow, Kurt, Troy Mar 2 '18 at 21:36

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    That looks very much like disambiguation of the name Johnson. Which means you probably have some other Johnson in your references, and biblatex distinguishes them by adding other name parts. If you don't want that to happen, you should use the option uniquename=false. But, once you already have that in your options, along with uniquelist=false, I'd say we probably would have to be able to reproduce the problem somehow to be able to find the culprit. That is, we would have to see a minimal working example with bibliography (MWEB). – gusbrs Mar 2 '18 at 2:09
  • 2
    As far as I know this behavior is controlled by these two options. These options are also settable on a per-entry basis, which means they may be overridden by your entries options. But I doubt we will be able to help unless you show us some code which reproduces the problem. – gusbrs Mar 2 '18 at 2:26
  • 2
    Post the problematic .bib entries? Maybe somebody will spot something. Also look in the .log and .blg files for anything relevant and see if you can spot differences in the .bbl. – cfr Mar 2 '18 at 2:38
  • 1
    The behaviour you describe definitely looks as though uniquename is not actually properly disabled. Do you have other settings for the bibliography that you have not shown us? Add \makeatletter\blx@uniquename\makeatletter to the very first page of your document and tell me what number you see (0, 1 or 2?). What version of biblatex and Biber do you have? – moewe Mar 2 '18 at 5:55
  • 4
    I'm voting to close this question as off-topic because it was solved in the comments. – gusbrs Mar 2 '18 at 21:11

Browse other questions tagged or ask your own question.