7

I'm trying to make a single-spaced glossary using the glossaries package but it seems as though the package has a default level of spacing in between entries even in single-spaced mode for the document. I'm using the ut-thesis style, which is based on report.cls. Examples below. Double-spaced text:

\documentclass[11pt]{ut-thesis}
…
\usepackage[nonumberlist]{glossaries}
\makeglossaries
…
\begin{document}
\printglossaries
…
\end{document}

double

Single-spaced text:

\documentclass[11pt,singlespaced]{ut-thesis}
…
\usepackage[nonumberlist]{glossaries}
\makeglossaries
…
\begin{document}
\printglossaries
…
\end{document}

single

This is simply not single-spaced enough for my purposes. I checked the documentation for glossaries and I hope I didn't miss anything there but nothing for \printglossaries or otherwise seemed to indicate that spacing could be altered. I tried using the leading package to help my case. This is the best that I could come up with:

\documentclass[11pt,singlespaced]{ut-thesis}
…
\usepackage{leading}
\usepackage[nonumberlist]{glossaries}
\makeglossaries
…
\begin{document}
\leading{10pt}
\printglossaries
…
\end{document}

leading

It works okay and it's what I'm using right now but I'm not sure why I can't get it to be any better. Any ideas?

Also, I'm a bit new here so if someone feels like correcting my taxonomy with respect to tagging this question, please feel free.

8

Given the default glossary entry "style" isn't what you want, why not select another one via the \printglossary style options (e.g., \printglossary[style=altlist])? The manual sets out quite a few styles that might work for you.

Out of these, I expect that \printglossary[style=long] will work best. However, since this style relies on the longtable package, you'll need to be sure that glossary can access it.

Also, you might notice that the style=long option doesn't set glossary entry names in bold font as before. If you still want that, just add \renewcommand{\glsnamefont}[1]{\textbf{#1}} to your document preamble to get it back again.

  • 1
    This is great. style=index worked best for me. Thanks! – fideli Oct 16 '10 at 14:46
  • For the record there is a \printglossary and a \printglossaries command, and those options only work with the former. – Emilien Nov 25 '16 at 10:40
14

Solution: use

\renewcommand*{\glsgroupskip}{}

Explanation: Abbreviations are bunched according to the starting letter. In your example, you can see this additional spacing is between the A-list & B-list and the B-list & C-list. This is the normal behavior of the glossaries package and is useful whenever the glossaries run to several pages. For smaller glossaries, it doesn't make a lot of sense.

6

I solved this with \glsnogroupskiptrue before of \printglossary. I was using a custom style based in long style and for some reason remained the spacing skip between groups and \renewcommand*{\glsgroupskip}{} do not worked at all.

Oddly, it seem that only \glsnogroupskipfalse appear in the manual (page 8) . It should be evident that this is a boolean option that must have a opposite command, but it would have been better see it written.

  • As of now (v4.12, 2014-11-22), this command isn’t documented at all. I’m assuming that it’s no longer supported. But page 167 of the manual describes a specific solution for this case: either use \newglossarystyle or make the modifications after \setglossarystyle. – Konrad Rudolph Nov 4 '15 at 14:09
1

Solution: Set to true the boolean nogroupskip when print the glossary via the command printglossary

\printglossary[nogroupskip=true]

I was looking for the same feature, the comment of @Konrad Rudolph helped me, I checked the manual and It was right there at the page 167 related to the command printglossary

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.