3

When I BibTex compile my test.bib file using TexMaker I get an error that reads:

"I couldn't open file name `test.aux'"

and when I compile my .tex file using the sequence
PdfLatex => Bib(la)tex => PdfLatex (x2)
the Bib(la)tex compile gives the error

"I couldn't open file name `test.blg'"

Having looked through the directory I can't find a .blg or .bbl file for either the .tex file or the .bib file nor have I been able to get produce either of these.

My .tex file is as below:

\documentclass{article}

\begin{document}
This is a demo. \cite{greenwade93} \cite{jones2014predicting}

\bibliographystyle{plain}
\bibliography{test}
\end{document}

and my .bib file is

@article{greenwade93,
    author  = "George D. Greenwade",
    title   = "The {C}omprehensive {T}ex {A}rchive {N}etwork ({CTAN})",
    year    = "1993",
    journal = "TUGBoat",
    volume  = "14",
    number  = "3",
    pages   = "342--351"
}

@inproceedings{jones2014predicting,
    title       = "Predicting the optimum air permeability of a stock of detached English dwellings",
    author      = "Jones, Benjamin and Lowe, Robert",
    booktitle   = "Proceedings of 35th Air Infiltration and Ventilation Centre (AIVC) Conference, Poznan, Poland. Retrieved from http://www. aivc. org/sites/default/files/97. pdf",
    year        = "2014"
}
6
  • Welcome to TeX.SX! – Bobyandbob Mar 4 '18 at 12:53
  • 3
    bib(la)tex? That mean biblatex with biber engine, biblatex with bibtex engine, or simply bibtex ?? Your MWE is for the classical plain bibtex, not for biblatex. Remove all the auxiliary files and then run the compilation sequence with bibtex test in the second step. – Fran Mar 4 '18 at 12:53
  • @Fran I'm not sure which of those it is, I am just using the built-in TexMaker BibTex compiler. I have tried deleting the .aux files and re-running the compiler and still have the same issue unfortunately – insatiableturtle Mar 4 '18 at 15:24
  • Not only the .aux files, but all except the originals the .tex and .bib files. Your MWE works perfectly in my TexMaker. Check that your configuration for "Bib(la)tex" (Now I realize where that misleading expression comes from) is bibtex %.aux. If this fail, then try to compile your example without any editor (in the command line prompt) with the correct compiling sequences of that answer. In this answer is explained the difference among bibtex and biblatex and biber and the correct compiling sequence in each case. – Fran Mar 4 '18 at 16:55
  • 3
    Does this answer your question? biblatex .blg file not created on Windows – Maverick Jan 13 '20 at 13:37
1

I had the same problem. I discovered my antivirus blocked Bibtex.exe from accessing my folder. After I unblocked it, it worked.

3
  • That is actually a good answer. For Windows users this is definitely a possible issue. – Henri Menke Apr 7 '19 at 3:37
  • My antivirus is Bitdefender. It has an anti-Ransomware system that blocks access to the My Documents folder and my Latex files are in the My Documents folder. – Hezekiah Y. Samwini Apr 8 '19 at 6:37
  • Same problem here. I also have Bitdefender, however, the problem persists even after I completely disable the protection. – Maverick Jan 13 '20 at 12:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.