0

When I create a chapter heading using fncychap, it writes the word "chapter" in Hebrew (פרק), which makes sense given that Hebrew is the default language in this file.

  1. How can I change it to say something in English instead of Hebrew?
  2. How can I change it to say something other than "Chapter" (e.g., "Story" instead of "Chapter")?

MWE (xetex):

\documentclass{book}

\usepackage{microtype}  
\usepackage{expex}
\usepackage{polyglossia}
\setdefaultlanguage{hebrew}
\setotherlanguage{english}
\newfontfamily\hebrewfont[Script=Hebrew]{FrankRuehl}
\newfontfamily\englishfont{Times New Roman}
\usepackage[Conny]{fncychap} %Options: Sonny, Lenny, Glenn, Conny, Rejne, Bjarne, Bjornstrup

\lingset{
    everygla=\Large,
    everyglb=\scriptsize\englishfont,
    everyglc=\scriptsize\englishfont,
    glwordalign=center,
    glhangindent=0em,
    glrightskip=0pt,
   }

\usepackage{ifoddpage}

\newcommand{\swapboxes}[2]% #1 = wide text, #2 = narrow text
{\noindent\makebox[\textwidth]{\checkoddpage
 \ifoddpageoroneside
   \parbox[t]{.71\textwidth}{#1}\hfill\parbox[t]{.26\textwidth}{#2}%
 \else
   \parbox[t]{.26\textwidth}{#2}\hfill\parbox[t]{.71\textwidth}{#1}%
 \fi}}% this \swapboxes macro forces the parboxes to switch sides every odd page

\begin{document}
\chapter{title}

\swapboxes{\exdisplay\begingl
  \gla אאאא בבבב גגגג דדדד אא בב גג דד אאאא בב גגגג דדד אאאא בבבבב גג דדדד אא בבבב גגגגג דדד אאאא בבבב גגגג דדדד אא בב גג דד אאאא //

  \glb aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa  //

  \glc aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa //

\endgl \xe}{\exdisplay\footnotesize\textenglish{Here is some non lipsum text to fill up this space Here is some non lipsum text to fill up this space Here is some non lipsum text to fill up this space Here is the end} \xe}

\swapboxes{\exdisplay\begingl
  \gla אאאא בבבב גגגג דדדד אא בב גג דד אאאא בב גגגג דדד אאאא בבבבב גג דדדד אא בבבב גגגגג דדד אאאא בבבב גגגג דדדד אא בב גג דד אאאא //

  \glb aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa  //

  \glc aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa bbb ggg ddd aaaa //

\endgl \xe}{\exdisplay\footnotesize\textenglish{Here is some non lipsum text to fill up this space Here is some non lipsum text to fill up this space Here is some non lipsum text to fill up this space Here is the end} \xe}

\end{document}

Output:

enter image description here

  • I feel like @UlrikeFischer might be able to help. :) – AML Mar 6 '18 at 20:01
1

Redefine the \@chapapp-Command:

\documentclass{book}

\usepackage{microtype}
\usepackage{polyglossia}
\setdefaultlanguage{hebrew}
\setotherlanguage{english}
\newfontfamily\hebrewfont[Script=Hebrew]{Ezra SIL} %changed font
\newfontfamily\englishfont{Times New Roman}

\usepackage[Conny]{fncychap} %Options: Sonny, Lenny, Glenn, Conny, Rejne, Bjarne, Bjornstrup

\usepackage{ifoddpage}

\makeatletter
\renewcommand\@chapapp{Chapter}% or whatever
\makeatother
\begin{document}
\chapter{title}

\end{document}

enter image description here

  • I would like it to say "Chapter 1" instead of "1 Chapter". – AML Mar 7 '18 at 16:37
  • Any idea how to switch "Chapter" and "1"? This is the crux of the problem that I can't figure out. – AML Mar 8 '18 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.