7

When trying to uninstall (Settings >> Apps & Features >> Miktex 2.9 >> Uninstall) a regular Miktex 2.9 installation (user installation, not administrator) on Windows 10, I encounter the following error:

MiKTeX
---------------------------
Administrative startup refused because this is not a shared MiKTeX setup.
---------------------------
OK

Miktex itself is broken (some .exe files are missing, the updating process in Miktex Console fails with an error, execution of pdflatex doesn't work, etc.), so I'd like to completely uninstall it and do a fresh new installation. Any help is appreciated.

6
  • 2
    Note that MIkTeX might not be broken: The Package Manager has been removed and replaced by 'MikTeX Console' (see github.com/MiKTeX/miktex/issues/86). But at least on my installation the start menu links for the Package Manager remained leaving the impression of a broken installation.
    – moewe
    Commented Mar 6, 2018 at 22:57
  • If nothing else works, try brute force: Manually delete the MikTeX program folder, and anything involving MikTeX in your ProgramData and User AppData (hidden) folders. Then use a registry cleaner (such as CCleaner) to get rid of dead registry entries. Then reinstall. I recommend a portable installation: Never given me trouble, and I can occasionally make a zip archive of the whole thing.
    – user139954
    Commented Mar 7, 2018 at 0:11
  • 1
    Thanks for your comments, I added the necessary information in my question. Its a user installation, to uninstall I just used control panel. Not sure if that's a user or administrator uninstallation, but from the error message I'd guess that control panel tries administrator uninstall. How to change that behaviour?
    – leosh
    Commented Mar 7, 2018 at 9:47
  • I'm aware of the change to Miktex Console, but that also doesn't function well. On the first page, it tells me that the PATH is not set correctly (although it is, I can call "latex" or "pdflatex" from any folder). Moreover, the displayed installation path mixes both unix and windows path notations (backslash \ and slash / for folders), so I think that may be a problem. Moreover, some exe files are missing in the installation folder, leading to a crash of the Miktex Console package updating process.
    – leosh
    Commented Mar 7, 2018 at 9:49
  • Maybe tex.stackexchange.com/q/231131/35864 helps. If you didn't install as admin you probably want uninstall.exe and not uninstall_admin.exe. BTW: My MikTeX has mixed slashes and that is not a problem at all C:\Program Files\MiKTeX 2.9\miktex/bin/x64 works just fine.
    – moewe
    Commented Mar 8, 2018 at 13:39

3 Answers 3

1

For me, I found that the error message was correct: I hadn't installed MiKTeX for all users (i.e. "not shared") and therefore admin rights were not needed to uninstall. I don't know why the uninstaller is not smart enough to handle this scenario, but the solution is simple:

Open the MiKTeX Console as usual (no admin rights), go to the "Cleanup" tab, then select Uninstall (screenshot below).

miktex uninstall via console

You can find MiKTeX Console via the Start Menu shortcut, or, in my case, at this path: C:\Programs\MiKTeX 2.9\miktex\bin\x64\miktex-console.exe

4

Deleting any tex-related files manually from my computer and running a registry cleaner (such as CCleaner) before re-installing Miktex 2.9 solved the issue. Use the Windows search to find all files, they might be distributed in the entire system: C:\Program Files, C:\Users\User\AppData\Roaming, C:\Users\User\AppData\Local, etc.

0

I had exact same problem. Not being able to delete with the same error messages. Also, not compiling TeX files which can be compiled in other computers. I realized that there is a program called "MikTex Console" in Programs and Apps. So, I first uninstall the MikTex Console. Then, I was able to uninstall MikTex itself.

1
  • I did exactly the same as you (user7777791). And it works! Thank you! Commented Jul 25, 2021 at 13:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .