16

Cheers,

I'm wondering how to use only serif fonts in whole document. Remark: I use one of the koma-script document classes, which employ sans-serif fonts for chapter and sectioning headers.

I've managed to change the tableofcontents with koma, but e.g. setkoma commands won't work for all the headings.

Thank you a lot in advance!

mldmnn

This is my main document:

\input{chapter/header}
\setlength{\unitlength}{1mm}
\makeindex
\makenomenclature

\begin{document}%

\begin{spacing}{1}%Normal Spacing
\renewcommand*{\theHchapter}{0.\arabic{chapter}} %so that no double Chapter I (prob with hyperref)
\pagenumbering{roman}
\setcounter{secnumdepth}{-1} %No number in front of Chapter
\maketitle 

\clearpage
\thispagestyle{empty}
\hfill
\clearpage

\input{chapter/Declaration}

\clearpage
\thispagestyle{empty}
\hfill
\clearpage

\input{chapter/Abstract}

\clearpage
\thispagestyle{empty}
\hfill
\clearpage

\renewcommand*{\theHchapter}{\arabic{chapter}} %so that no double Chapter I (prob with hyperref)
    %TOC etc.
\setcounter{secnumdepth}{4} %Numbers in front of Chapter etc
\setcounter{tocdepth}{4} 
\pagenumbering{Roman}

This is my header.tex:

\documentclass[a4paper,%
                            english,%
                            numbers=noenddot,%not 1.1. but 1.1 (früher: pointlessnumbers)
                            oneside,%
                            bibliography=totoc,%früher: bibtotoc
                            listof=totoc,%früher: liststotoc
                            %draft
]{scrreprt}
\usepackage[pdftex]{graphicx}
\pdfoutput=1
\pdfcompresslevel=9
%\DeclareGraphicsRule{.tif}{bmp}{}{}            %see epslatex.ps
\DeclareGraphicsExtensions{.pdf,.png,.jpg,.mps} %see epslatex.ps
\graphicspath{{bilder/}}
\usepackage[english]{babel}

\usepackage[latin1]{inputenc}%zuständig für umlaute und scharfes s (ß)
6
  • 2
    Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. Mar 7, 2018 at 14:56
  • 2
    \renewcommand\sfdefault{\rmdefault} ? Mar 7, 2018 at 14:59
  • 6
    Are you looking for the document class option egregdoesnotlikesansseriftitles? Mar 7, 2018 at 15:01
  • 1
    I can't compile your mwe.
    – Tarass
    Mar 7, 2018 at 15:04
  • 1
    Please don't remove your code. You might consider editing it to make it more minimal, but deleting it now you've got an answer is just destructive.
    – cfr
    Mar 8, 2018 at 4:28

1 Answer 1

34

To make all the headings "no sans serif" - or for short "serif" - there is a special documentclass option:

\documentclass[egregdoesnotlikesansseriftitles]{scrbook}

\begin{document}
\chapter{test}
test
\end{document}
21
  • 12
    @StevenB.Segletes you have to be really annoying to make a package author add such an option:-) Mar 7, 2018 at 15:04
  • 4
    @DavidCarlisle "The only thing worse than being talked about...is not being talked about." -O. Wilde Mar 7, 2018 at 15:06
  • 6
    I suspect that the option "egregdoesnotlikesansseriftitles" was, until now, the most obscure and/or least-documented of all options of the koma-script document classes. No more! :-)
    – Mico
    Mar 7, 2018 at 15:14
  • 5
    @mldmnn Another way to picture it is this, your profile, tex.stackexchange.com/users/156599/mldmnn, shows your presence on this site has reached a total of 28 people, at this moment. Compare it to tex.stackexchange.com/users/4427/egreg, which shows that, at the moment, egreg has reached a total of 33.7 million people by his presence here. One may not always agree with egreg's preferences, but one should never foolishly ignore his advice. Gravitas!!! Mar 7, 2018 at 15:40
  • 14
    Best option name ever!
    – egreg
    Mar 7, 2018 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.