0

The cross-references in my document used to work. But recently I found all the references to the equations are shown as ?? (question marks). I am not sure whether this is because I revised or added something in the preamble. I did compile multiple times but it does not help.

Part of my document is shown below

\documentclass[3p,twocolumn,authoryear]{elsarticle}
\usepackage{amssymb}
\usepackage{epstopdf} %for inserting .eps figure.
\usepackage{color} %for using color
\usepackage{float} %for placing the float (figure) at precisely the location in the LaTeX code
\usepackage{amsmath} % for using normal text in math mode 
\usepackage[multiple]{footmisc} %for using multiple footnotes at one point
\usepackage{enumitem} % for using enumerate
\usepackage{makecell}
\usepackage[labelformat=simple]{subcaption} %for using subfigures, and 
\renewcommand\thesubfigure{(\alph{subfigure})} %will add a parenthesis for references
\usepackage{mathtools} 
\usepackage{bm} % for using bold math font
\usepackage{cleveref}
\usepackage[hidelinks]{hyperref}
\newtheorem{thm}{Theorem}
\newtheorem{lem}[thm]{Lemma}
\newdefinition{rmk}{Remark}
\newproof{pf}{Proof}
\newproof{pot}{Proof of Theorem \ref{thm2}}
\setlist[enumerate]{itemsep=0.3ex}


\def\blue#1{{\color{blue} #1}}
\def\black#1{{\color{black} #1}}
\definecolor{red}{rgb}{1,0,0}
\def\red#1{{\color{red}#1}}


\journal{Control Engineering Practice}

\begin{document}

\begin{frontmatter}
\end{frontmatter}

\begin{equation}\label{eq:PltDyn_TF}
%P(s)=  (P_1(s)+P_2(s))e^{-\tau_ds},
P(s):=e^{-\tau_ds}\sum_{i=1}^2 \frac{K_i\omega_i^2}{s^2+2\zeta_i\omega_is+\omega_i^2},
\end{equation}
...
the model \eqref{eq:PltDyn_TF}. 
\end{document}

1 Answer 1

1

Package cleveref must be loaded after package hyperref.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .