1

I have an inflexible formatting requirement from my publisher for typesetting the text area. Top, bottom, left, right margins must each be 2cms on an A4 paper. The text area includes all headers and footers. The geometry package - to my understanding - provides all functionality required for achieving the goal. However, in my MWE the bottom margin is just too large. I do not know why.

Highly appreciate your support!

 \documentclass[12pt]{scrbook}

 \usepackage[a4paper, left=2cm, right=2cm, top=2cm, bottom=2cm, includeheadfoot]{geometry}

 \usepackage{scrpage2}
 \pagestyle{scrheadings}
 \clearscrheadfoot
 \rehead{\headmark}
 \lehead{\pagemark}
 \lohead{\headmark}
 \rohead{\pagemark}

 \usepackage{lipsum}

 \begin{document}
 \section{test}
 \lipsum[1]
 \lipsum[1]
 \lipsum[1]
 \lipsum[1]\footnote{test}
 \lipsum[1]

\end{document} 
  • Use the showframe option in geometry, so you can see it better. Also, you can control the space for footer with foot=1cm, for example. – Sigur Mar 9 '18 at 22:09
  • 1
    Your foot is empty, but if you add something with e.g. \ofoot{yyyyyyyyyyXXXXXXXX} the spacing looks okay. – Ulrike Fischer Mar 9 '18 at 22:13
  • Or (a variation of Ulrike's suggestion) use includehead instead of includeheadfoot if you really don't need the footer. – gusbrs Mar 9 '18 at 22:19
  • Thanks for the quick comments. I set foot=0cm. :-) Also, I really like the showframe option to understand the geometry package better. Thanks again! – desp_user Mar 9 '18 at 22:56
2

If there should be no space for footer add nofoot to the options of package geometry:

\documentclass[12pt]{scrbook}

\usepackage[
  margin=2cm,% each margin should be 2cm
  includeheadfoot,% text area includes header
  nofoot,% no space for footer
  %showframe% show the page layout
]{geometry}

\usepackage[automark]{scrpage2}
\pagestyle{scrheadings}
\clearscrheadfoot
\ohead{\pagemark}
\ihead{\headmark}

\usepackage{lipsum}% only for dummy text

\begin{document}
\chapter{Foo}
\lipsum[1-6]
\section{test}
\lipsum[1]
\lipsum[1]
\lipsum[1]\footnote{test}
\lipsum[2-20]
\end{document}

Result with option showframe:

enter image description here


Of topic: Note that package scrpage2 is outdated since 2014. Its successor is scrlayer-scrpage:

\usepackage[automark]{scrlayer-scrpage}% sets pagestyle scrheadings automatically
\clearpairofpagestyles
\ohead{\pagemark}
\ihead{\headmark}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.