1

I'm encountering a problem when using Overleaf. I've used \usepackage[dutch]{babel} and my table of contents and header of my bibliography is all Dutch, which is great. However, my bibliography itself, is in English.

For example when I quote a chapter in a book, the bibliography says chapter 582 or first edition, whereas it should say hoofdstuk (Dutch for chapter) 582 and first editie (Dutch for edition).

I've tried \bibliography{bib.bib}{dutch} , but that did not work.

4
  • 1
    With biblatex, you can have different languages. With classic bst files, not. – Johannes_B Mar 12 '18 at 14:23
  • 1
    It depends a bit on the BibTeX style you're using, too, e.g. apacite does have Dutch support. Most BibTeX styles don't have multilingual language support. – imnothere Mar 12 '18 at 14:28
  • I use Overleaf and bibliographystyle{unsrt} – Nienke Mar 12 '18 at 14:52
1

You can use the package babelbib, which has support for Afrikaans, Bahasa, Catalan, Croatian, Czech, Danish, Dutch, English, Esperanto, Finnish, French, Galician, German, Greek, Italian, Norwegian, Portuguese, Romanian, Russian, Serbian, Spanish, and Swedish. It provides translated versions of plain, alpha, unsrt and abbrv. With the option fixlanguage it assumes the language provided to babel is desired for the bibliography.

MWE (note that the filecontents part is not necessary, it's just to create a .bib file on the fly):

\begin{filecontents}{\jobname.bib}
@inbook{mychapter,
    author = {Jan Jansen},
    title = {Interessante Verhandeling},
    chapter = {3},
    publisher = {ABC Boeken},
    year = {2018}
}
\end{filecontents}
\documentclass{article}
\usepackage[dutch]{babel}
\usepackage[fixlanguage]{babelbib}
\begin{document}
Zie \cite{mychapter}.

\bibliographystyle{babunsrt}
\bibliography{\jobname}  % replace \jobname with the name of your bib file
\end{document}

Result:

enter image description here

3
  • Thanks that worked! I did however in addition need to change \usepackage{natbib} to \usepackage[numbers]{natbib} or otherwise I would get an error. – Nienke Mar 13 '18 at 10:02
  • Could you please tell me how to create the .bib file? – Twink Feb 22 at 0:26
  • @Twink I'm not really sure I understand your comment. Does it have to do with the current question or answer about changing the language for a bibliography made with bibtex? Or do you have a different question about bibliographies? If your comment was about this question, then you should clarify what you mean exactly. If it is a different question, then you should start a new question by pressing the 'Ask Question' button on the top of the page. – Marijn Feb 22 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.