0

I am trying to run some latex files on a new computer. I am using an external hard drive that is a direct copy of my previous computer so the files all should be fine, however I am getting the error:

Sorry, but "MiKTeX Compiler Driver" did not succeed.
The log file hopefully contains the information to get MiKTeX going again:
  C:/Users/******/AppData/Local/MiKTeX/2.9/miktex/log/texify.log
You may want to visit the MiKTeX project page, if you need help.

I have found lots of threads on this, but none of the solutions given have worked for me. I have tried deleting aux files and re-running, I have tried running from command prompt, I have tried uninstalling and reinstalling MiKTeX, I have tried running initexmf --mkmaps --verbose from the command prompt. The log file it directs me too reads as follows:

2018-03-15 11:36:30,425Z INFO  texify - starting with command line: 
"C:\Program Files\MiKTeX 2.9\miktex\bin\x64\texify.exe" --pdf --synctex=1 --clean warwickthesis.tex
2018-03-15 11:36:49,382Z FATAL texify - BibTeX failed for some reason.
2018-03-15 11:36:49,382Z FATAL texify - Info: 
2018-03-15 11:36:49,382Z FATAL texify - Source: 
Programs\MiKTeX\texify\mcd.cpp
2018-03-15 11:36:49,382Z FATAL texify - Line: 1286

I have since tried running just pdflatex - this works but obviously does not create references etc. Running just bibtex does not work and returns this in the blg file:

This is BibTeX, Version 0.99dThe top-level auxiliary file: warwickthesis.aux
The style file: unsrt.bst
Database file #1: library.bib
Repeated entry---line 1242 of file library.bib
 : @article{Takishita2015
 :                       ,
I'm skipping whatever remains of this entry
Repeated entry---line 1396 of file library.bib
 : @article{Grassie2005
 :                     ,
I'm skipping whatever remains of this entry
Warning--I didn't find a database entry for "Haidemenopoulos2016"
Warning--I didn't find a database entry for "Hughes2015"
Warning--I didn't find a database entry for "Blitz1997"
Warning--I didn't find a database entry for "Bieber1998"
Warning--I didn't find a database entry for "Tian2005"
Warning--I didn't find a database entry for "Mina1997"
Warning--I didn't find a database entry for "Drinkwater2006"
Warning--I didn't find a database entry for "Grimberg2006"
Warning--I didn't find a database entry for "Edwards2008a"
Warning--I didn't find a database entry for "Gros1999"
Warning--I didn't find a database entry for "Hughes2014"
Warning--I didn't find a database entry for "Honarvar2013"
Warning--I didn't find a database entry for "Alvarez-Arenas2013"
Warning--I didn't find a database entry for "Kang2017"
... etc (few more of these)
Warning--empty journal in Ewert2013
Warning--can't use both author and editor fields in Achenbach1999
Warning--empty journal in Blake1990
Warning--empty note in Thring2018
(There were 2 error messages)

This is odd as the references are in my library created by Mendeley and the referencing works fine on a different computer.

Any suggestions?

  • 3
    Don't use texify when you have a problem. It's error messages are often bad or meaningless. Call the tools individually. – Ulrike Fischer Mar 15 '18 at 12:40
  • Ulrike Fischer, I'm sorry I don't know how to do that, could you elaborate for me? – Claire Thring Mar 15 '18 at 13:51
  • Delete the auxiliary files (toc, aux,bbl). Run only pdflatex. If it doesn't succeeds find out why pdflatex fails by checking the log-file and correct the error. If it succeeds run bibtex. Check the blg if it did succeed. If yes run pdflatex again. – Ulrike Fischer Mar 15 '18 at 14:02
  • Ok, it now runs with just pdflatex, although it didn't before strangly. It does not run with bibtex. This is the log file: 2018-03-15 14:09:35,734Z INFO miktex-bibtex - starting with command line: "C:\MiKTeK Program Files\miktex\bin\x64\miktex-bibtex.exe" warwickthesis 2018-03-15 14:09:35,805Z INFO miktex-bibtex - finishing with exit code 1 This error doesn't tell me any more though? It does not seem to like my library, however it is the same one I used on a different computer which worked fine? – Claire Thring Mar 15 '18 at 14:11
  • 1
    Edit the question to add the info. – Ulrike Fischer Mar 15 '18 at 16:00
1

I've had a similar issue since I have started compiling my thesis on my laptop rather than the machine at work and I am guessing they are different versions of Miktex or TexWorks. This error seems to occur when a reference is in the the bibtex file twice.

However if you have citation names that are separated by an underscore it doesn't read past the underscore. My bibtex file is created automatically by Zotero using the format "author_firstwordtitle_year", i.e. jones_paper_2018 or jones_anotherpaper_2018. When you compile it, it reads these two references as the being the same and hence the error occurs. I've just about finished my thesis so have manually added a number at the beginning to give me 1jones_paper_2018 and 2jones_anotherpaper_2018 and it works. This would however be a pain if I was still working on it and updating my bibtex file regularly as I would have to keep manually updating the automatically generated list.

I have no idea what problem the update that I assume has been made to MikTex/TexWorks has solved as it just seems to me it has made the whole thing worse.

1

I also encounter a similar problem. I.E. MiKTeX compiler driver did not succeed.

The problem is that I give the LaTeX file a name that with spaces. When I deleted all the spaces in the file name, then everything was fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.