I am using Latexit to generate latex for some powerpoint slides. LatexIt is an equation editor that makes it easy to generate equations and export them as PNG, PDF, SVG, etc to use in other programs, without going through the hassle of creating a full document yourself. Its website is:


My problem: I can't seem to get the inline math characters to be larger using \displaystyle:

this is a test sentence for $\mathcal{D}$ inline math $f$ in $g$ this sentence.

renders as:

enter image description here

I want the characters to be larger, bolder, etc.

My Minimum Working Example illustrating the problem consists of the template below, and the line above.

My template is:

%\usepackage[utf8]{inputenc} %useful to type directly diacritic characters
\usepackage[usenames]{color} %used for font color
\usepackage{amssymb} %maths
\usepackage{amsmath} %maths

% Seaborn Colors


% Color shortcuts
  • 1
    The preamble you posted bears no relation with the issue you are reporting. The standard behavior in LaTeX is to have the sizes of the fonts used in mathematical formulas scale with the size of the text they are embedded in, so there’s something strange in the behavior you reported. Please add more details and provide a Minimal Working Example. – GuM Mar 20 '18 at 18:44
  • @guM This isn't as trivial to do as it seems, since LaTeXit is an app designed for making snippets of code, so a traditional MWE might not be of help. – Alan Munn Mar 20 '18 at 19:11
  • @AlanMunn: It’s not clear, actually, what the OP is doing: (s)he seems to be writing an article using some “template” source code, isn’t (s)he? – GuM Mar 20 '18 at 19:14
  • @GuM No. This is the preamble for the snippet maker. It's a Mac program. – Alan Munn Mar 20 '18 at 19:16
  • thank you @AlanMunn, I've edited the question with more details about latexit. – user79950 Mar 20 '18 at 19:30

I don't have the Roboto font, so I can't test this exactly, but with the following preamble:

\usepackage[svgnames]{xcolor} %used for font color
\setmainfont[Scale=MatchLowercase]{DejaVu Sans}
\usepackage{amssymb} %maths

I get the following output:

output of code

So try loading adding the [Scale=MatchLowercase] option to your \setmainfont command.

Using the Roboto font I get a similar result:

enter image description here

  • thanks for your response Alan. It seems that does work, when I downloaded and installed DejaVu Sans. It did not work with Roboto font. I'm not sure why that matters, as I am just trying to render the latex math font larger. – user79950 Mar 20 '18 at 19:38
  • @user79950 That's odd, since I just downloaded Roboto and it works for me. – Alan Munn Mar 20 '18 at 19:40
  • hm. I had to first render with DejaVu, see it, then change to roboto, restart, and it worked. Not sure whats going on, but I will accept this answer. Thanks! – user79950 Mar 20 '18 at 20:05
  • do you know how to make it larger than that? – user79950 Mar 21 '18 at 22:24
  • @user79950 You can try adding \DeclareMathSizes{10}{12}{9}{7} to the preamble. See how to scale math font only for more details. – Alan Munn Mar 22 '18 at 2:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.