3

I am facing weird problems trying to load the siunitx package. Version 2.7l is installed, all compulsory packages as well. I produced a minimal example where the same error occurs:

\documentclass[a4paper, 12pt, oneside, headsepline, ngerman, openany, headings=small]{scrbook}

\usepackage{cancel}
\usepackage{caption}
\usepackage{cleveref}
\usepackage{csquotes}
\usepackage{helvet}
\usepackage{mathpazo}
\usepackage{listings}
\usepackage{pgfplots}
\usepackage{xcolor}

\usepackage{siunitx}
    \sisetup{
        detect-mode,
        tight-spacing       = true,
        group-digits        = false ,
        input-signs     = ,
        input-symbols       = ( ) [ ] - + *,
        input-open-uncertainty  = ,
        input-close-uncertainty = ,
        table-align-text-post   = false
        } 


\begin{document}

\si{1,2,3}

\end{document}

The error message tells me there is something wrong with the style file of the package:

! Undefined control sequence.
<argument> \seq_const_from_clist:Nn
\c__siunitx_old_options_seq {addsign,all...
l.258 }
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

! Undefined control sequence.
    <argument> ...list:Nn \c__siunitx_old_options_seq
    {addsign,allowlitunits,all...
    l.258 }

! LaTeX Error: Missing \begin{document}.
    See the LaTeX manual or LaTeX Companion for explanation.
    Type H <return> for immediate help.
    ...
    l.258 }

Maybe someone has an idea how I can handle it. Thank you in advance.

  • 1
    I can run your code without problems (updated last week, MiKTeX, Win10). Maybe try to update your system again. As a last resort, deinstall and reinstall. – Dr. Manuel Kuehner Mar 20 '18 at 18:58
  • Almost certainly you have an old version of l3kernel: are you using MiKTeX? – Joseph Wright Mar 20 '18 at 19:03
  • The code works for me without problem on a fully updated MikTeX distribution on Windows 10. Your siunitx is up to date, so probably one of the l3 packages is outdated. Have you tried an update? – moewe Mar 20 '18 at 19:40
  • 1
    Thank you! I reinstalled MiKTeX and after some adaption the code runs finally. Thank you all very very much – marieke Mar 20 '18 at 20:09
  • Unrelated to your problem, you might consider newpxmath as a replacement for mathpazo. Or even unicode-math with \setmainfont{TeX Gyre Pagella} and \setmathfont[Scale=MatchUppercase]{Asana Math}. – Davislor Jul 29 '18 at 2:58
2

With the intention of adding more details, I verified that this is a version compatibility problem with Miktex and the siunitx package that is imported in the latest version. In my case the problem was with Miktex-2.9.6361 and it was fixed by installing Miktex-2.9.6643, which has important changes like how to manage packages and updates that is now done through a single interface called Miktex console.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.