1

I would like to use Arial font in a document in Sharelatex.

I have found in other posts that I should use XeLatex or LuaLatex:

\usepackage{fontspec}
\setmainfont{Arial}

Xelatex is giving error due to a timeout. And LuaLatex return an error:

 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!
! fontspec error: "font-not-found"
! 
! The font "Arial" cannot be found.
! 
! See the fontspec documentation for further information.
! 
! For immediate help type H <return>.
!...............................................  

l.24 \setmainfont{Arial}

|'''''''''''''''''''''''''''''''''''''''''''''''
| A font might not be found for many reasons.
|  Check the spelling, where the font is installed etc. etc.
| 
|  When in doubt, ask someone for help!
|...............................................

Someone have a clear and easy method to solve my question?

  • Welcome to TeX.SE! Could you provide a small, complete document that uses Arial which results in the errors you describe?With such a document it's much easier for the community here to answer your question. – Marijn Mar 23 '18 at 14:06
  • @Marijn, I edited my post – Dadep Mar 23 '18 at 14:16
  • 1
    this is already more informative. Maybe sharelatex.com/blog/2013/04/02/… has a solution for your problem? If you have tried the steps on that page and it still doesn't work then try the example document presented on that page (with Arial instead of Times) and post any errors you get in your question here. – Marijn Mar 23 '18 at 14:29
1

Thanks to Merijn comment and this page, I found a solution :

The .ttf should be add to the project. And then the use specify in the main file :

example :

\documentclass[12pt]{article}
\usepackage{fontspec}
\setmainfont[Ligatures=TeX]{Arial.ttf}
\begin{document}
This is the document text; 
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.