0

I'm trying to switch the language in the bibliography to german, but so far I had no luck with all the hints from the internet.

Here is the code in overleaf, I'm using:

\documentclass[12pt,a4paper]{article}
%% Entspricht Zeilenabstand 1.5 in Word
\linespread{1.25}

%% für Querformat
\usepackage{lscape}

%% Rotation des Textes
\usepackage{graphicx}

%% Language and font encodings
\usepackage[ngerman]{babel}
\usepackage[ngerman]{datetime} 
\usepackage{babelbib}
%\usepackage{babelbib}
\newdateformat{myformat}{\THEDAY{. }\monthnamengerman[\THEMONTH] \THEYEAR}
\usepackage[T1]{fontenc}
\usepackage{mathptmx} % Times New Roman ähnliche Schrift
\usepackage{enumitem}
\usepackage[normalem]{ulem} %% Für Unterstrich (\Uline)
\newcommand\tab[1][1cm]{\hspace*{#1}} %% für Tabluator (\tab)
%\addto\captionsenglish{\renewcommand{\referencesname}{Referenz} }
\usepackage{float} %%Bildpositionierung
\restylefloat{figure} %Bildpositionierung
%%Querverweise  
\usepackage{prettyref}
\usepackage{titleref}
%%% Für Abschnitt %%%
\newrefformat{sec}{Abschnitt~\ref{#1}}
%%\newrefformat{sec}{Abschnitt~\ref{#1}\ auf Seite \pageref{#1}}
%%% Für nur Abschnitte %%%
\newrefformat{sec1}{~\ref{#1}}
%%% Für Abbildungen %%%
\newrefformat{fig}{Abbildung~\ref{#1}\ auf Seite \pageref{#1}}
%%% Für Abbildung %%% 
\newrefformat{fig1}{Abbildung~\ref{#1}}
\newrefformat{tab}{Tabelle~\ref{#1}\ auf Seite \pageref{#1}}
\newrefformat{tab1}{Tabelle~\ref{#1}}
%%% Parallele Grafiken %%%
\usepackage{subfigure} 

%% Sets page size and margins
\usepackage[a4paper,top=3cm,bottom=2cm,left=3cm,right=3cm,marginparwidth=1.75cm]{geometry}

%% Useful packages
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage[colorinlistoftodos]{todonotes}
%% Hyperlink aktiviert / deaktiviert
\usepackage[colorlinks=true, allcolors=blue]{hyperref}
% URL Zeilenumbruch 
\apptocmd{\UrlBreaks}{\do\f\do\m}{}{}

% glossary
\usepackage[xindy={language=german,codepage=utf8}]{glossaries}
\setglossarystyle{treehypergroup}
\input{glossary}
\makeglossaries
%End glossary

%comments
\usepackage{comment}
%end comments

\addto\captionsenglish{\renewcommand{\figurename}{Abb.}}
\addto\captionsenglish{\renewcommand{\tablename}{Tab.}}
\addto\captionsenglish{\renewcommand{\contentsname}{Inhaltsverzeichnis} }
\addto\captionsenglish{\renewcommand{\glossaryname}{Glossar} }
\addto\captionsenglish{\renewcommand{\refname}{Literaturverzeichnis} }
\addto\captionsenglish{\renewcommand{\listfigurename}{Abbildungsverzeichnis}}
\addto\captionsenglish{\renewcommand{\listtablename}{Tabellenverzeichnis}}
\setlength{\parindent}{0pt}
\begin{document}

....

%Literaturverzeichnis
\bibliographystyle{alphaurl}
%\bibliographystyle{gerplain}% or babplain-fl
%\bibliographystyle{gerplain} 
%\bibliographystyle{apalike}
\bibliography{Zotero.bib}
\pagebreak
\section*{Anhang}
\end{document}

eg: alphaurl -> works basically, but I get wrong AND instead of UND between two autors

unsrtdin -> Bibliography (?) Error:

enter image description here

Do you have any hints that could work in this setup? Thanks!!

  • 4
    @Luke: The bibliographystyle you chose seems to be incompatible with the language specifications of babelbib. Would switching to biblatex be an option for you? – leandriis Mar 25 '18 at 17:03
  • Thanks @leandriis, I now get an biblatex error "incompatible package ucs" -> seems like \usepackage[utf8]{inputenc} is used to solve that... but this leads to an other error: Package biblatex Error: File 'main.bbl' not created by biblatex – Luke Mar 26 '18 at 8:06
1

I ended up with using the comibination:

% Language and font encodings
\usepackage[ngerman]{babel}
\usepackage[ngerman]{datetime} 
\usepackage{babelbib}

... at the end, inserting:

\bibliographystyle{alphadin} 
\bibliography{Zotero.bib}

With this style, there are no AND used between authors at all... So it's kind of a workaround.

HTH Luke

| improve this answer | |
  • did you try to load polyglossia package and then use \setmainlanguage{german}? in that case you must compile your document using xelatex or lualatex engine – Yorgos Jan 7 '19 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.