2

I tried to run a file at Hebrew with LyX (at XeTeX), and here is the message I get:
xdvipdfmx:fatal: Cannot proceed without the font: C:/ProgramData/MiKTeX/2.9/fonts/type1/public/culmus/DavidCLM-MediumItalic.pfa

But the file is there! (at this specific address)
How can I fix this?

Thank you!

(P.S. at pdflatex it's work fine, but I need to use XeTex)

  • 2
    Is it the same case? (I don't expect this to make a difference since most Windows file systems are not case-sensitive, but still worth checking). Does the file have correct permissions? – scottkosty Mar 25 '18 at 19:01
  • @scottkosty what do you mean when you say: "Is it the same case?" (but I think the answer is yes... and yes - the file have the correct permissions) – heblyx Mar 25 '18 at 19:16
  • you shouldn't use type1 fonts with xelatex. – Ulrike Fischer Mar 25 '18 at 19:51
  • @UlrikeFischer I use .pfa files... And if it's not good, how do I change it? I'm using LyX... – heblyx Mar 25 '18 at 20:45
  • .pfa is a type1 format (see the folder the file is in). And you should use fontspec and .ttf oder .otf font. – Ulrike Fischer Mar 25 '18 at 20:51
3

The Culmus fonts, including David CLM, are available from the Culmus Project.

XeTeX supports modern desktop fonts and Unicode, and I highly recommend that’s what you use. If you really do want to use legacy fonts instead, Culmus links to Iddo Samet’s package for MikTeX on Windows, and there is also the culmus-latex package.

Unfortunately, \usepackage[hebrew]{babel} with fontspec is broken (The version of hebrew.ldf included with babel 3.22 was last updated in 2005 and only supports obsolete 8-bit LHE fonts.) but polyglossia works just fine. Always save your source as UTF-8 when using XeTeX or LuaTeX.

\documentclass[varwidth=4in, preview]{standalone}
\usepackage{fontspec}
\usepackage{polyglossia}

\setdefaultlanguage{hebrew}

\defaultfontfeatures{ Scale = MatchUppercase, Ligatures = TeX }
\newfontfamily\hebrewfont{Taamey David CLM}[
  Script = Hebrew ,
  Language = Hebrew ]

\begin{document}
\section{בראשית}
\textbf{בְּרֵאשִׁ֖ית}
 בָּרָ֣א אֱלֹהִ֑ים אֵ֥ת הַשָּׁמַ֖יִם וְאֵ֥ת הָאָֽרֶץ׃ 
וְהָאָ֗רֶץ הָיְתָ֥ה תֹ֙הוּ֙ וָבֹ֔הוּ וְחֹ֖שֶׁךְ עַל־פְּנֵ֣י תְה֑וֹם וְר֣וּחַ אֱלֹהִ֔ים מְרַחֶ֖פֶת עַל־פְּנֵ֥י הַמָּֽיִם׃ 
וַיֹּ֥אמֶר אֱלֹהִ֖ים
\textit{יְהִ֣י א֑וֹר}
 וַֽיְהִי־אֽוֹר׃ 
וַיַּ֧רְא אֱלֹהִ֛ים אֶת־הָא֖וֹר כִּי־ט֑וֹב וַיַּבְדֵּ֣ל אֱלֹהִ֔ים בֵּ֥ין הָא֖וֹר וּבֵ֥ין הַחֹֽשֶׁךְ׃ 
וַיִּקְרָ֨א אֱלֹהִ֤ים ׀ לָאוֹר֙ י֔וֹם וְלַחֹ֖שֶׁךְ קָ֣רָא לָ֑יְלָה וַֽיְהִי־עֶ֥רֶב וַֽיְהִי־בֹ֖קֶר י֥וֹם אֶחָֽד׃
\end{document}

In the Beginning, ....

You could, if you prefer, select the language with the numerals = hebrew and calendar = hebrew options to get Hebrew numbers and dates.

Since the sample I picked included taamim, I used the Taamey David CLM font here, but for anything in Modern Hebrew, you wouldn’t need that and could substitute David CLM.

Addendum: \babelprovide[import]{hebrew} works with Babel 3.27, but not earlier.

|improve this answer|||||
1

This is a partial answer, or a lead for an answer.

I noticed that a .pfa David CLM font is not distributed with the Culmus project, as you can verify at the project website (by downloading the archive and seeing the file list). Some other fonts do have .pfas in the distribution archive, such as DrugulinCLM for example.

I'm also noticing you're trying to run xdvipdfmx. That does not sound like something that should happen when xelatex is generating a PDF - there shouldn't be any DVI files (which usually end up as PostScript in the end).

So, one of two things: Either you get your MikTeX to generate a .pfa for David CLM (is that even doable? I'm not sure), or make sure you are actually running xelatex and without a -no-pdf switch or something like that.

If xelatex does indeed use .pfas for PDFs, for some reason, also try the advice in an answer to this question: xelatex xdvipdfmx error, cannot proceed with font .

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.