3

I'm using Miktex 2.9 and TexStudio. I cannot compile anything, including this simple document:

\documentclass{article}

\begin{document}
    Test
\end{document}

The only error reported is "Process exited with error(s)". The log file contains this:

This is pdfTeX, Version 3.14159265-2.6-1.40.17 (MiKTeX 2.9.6210 64-bit) (preloaded format=pdflatex 2017.8.10)  28 MAR 2018 16:19
entering extended mode
**./texstudio_YJ9064.tex
(texstudio_YJ9064.tex
LaTeX2e <2017/01/01> patch level 1
Babel <3.9r> and hyphenation patterns for 75 language(s) loaded.
("C:\Program Files\MiKTeX 2.9\tex\latex\base\article.cls"
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
("C:\Program Files\MiKTeX 2.9\tex\latex\base\size10.clo"
File: size10.clo 2014/09/29 v1.4h Standard LaTeX file (size option)
)
\c@part=\count79
\c@section=\count80
\c@subsection=\count81
\c@subsubsection=\count82
\c@paragraph=\count83
\c@subparagraph=\count84
\c@figure=\count85
\c@table=\count86
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
)
(texstudio_YJ9064.aux)
\openout1 = `texstudio_YJ9064.aux'.

LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 3.
LaTeX Font Info:    ... okay on input line 3.
 [1

{C:/Users/USER/AppData/Local/MiKTeX/2.9/pdftex/config/pdftex.map
!pdfTeX error: pdflatex.exe (file C:/Users/David Scott/AppData/Local/MiKTeX/2.9
/pdftex/config/pdftex.map): buffer overflow at file C:\Jenkins\jobs\miktex-2.9\
workspace\source\Programs\TeXAndFriends\pdftex\source\mapfile.c, line 418
 ==> Fatal error occurred, no output PDF file produced!

To my knowledge, I did not change anything with my installation between when LaTeX worked and when it stopped.

3
  • 3
    buffer overflow. Well that's new. It looks as if your map-file is corrupted. Try to recreate it by calling updmap on a command line, or by using the task "recreate font map files" in the miktex console (as user). Commented Mar 28, 2018 at 8:26
  • Setting updmap as a user-defined tool in TexStudio worked! (Options->Configure->Build) Thanks a bunch! Do you want to post this as an actual answer so I can mark it as correct? Commented Mar 28, 2018 at 8:33
  • I added an answer. Could you also add the miktex tag to your question? Commented Mar 28, 2018 at 8:40

1 Answer 1

3
{C:/Users/USER/AppData/Local/MiKTeX/2.9/pdftex/config/pdftex.map
!pdfTeX error: pdflatex.exe (file C:/Users/David Scott/AppData/Local/MiKTeX/2.9
/pdftex/config/pdftex.map): buffer overflow at file C:\Jenkins\jobs\miktex-2.9\
workspace\source\Programs\TeXAndFriends\pdftex\source\mapfile.c, line 418
 ==> Fatal error occurred, no output PDF file produced!

This sounds as if pdftex.map is corrupted. You should recreate it and check if this resolves the problem.

As your map is in your user profile this can be done by calling either on a command line

updmap

or by using in the miktex console (started as user) the task recreate font map files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .