2

I'm finalizing my masters-thesis and can't get rid of an unwanted blank (with pagenumber) page after my title. Here my WME:

\documentclass[a4paper,DIV=10,twoside, BCOR=1cm, fontsize=12pt,         parskip=half]{scrreprt}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[english,ngerman]{babel}
\usepackage{csquotes}
\usepackage{lmodern}
\usepackage{setspace}
\setstretch{1.2}
\usepackage{pgfplots}
\pgfplotsset{compat=1.11}


%\subject{\vspace*{-1cm} Masterarbeit}
\subject{Masterarbeit}
\title{Title Title Title Title Title Title Title Title Title Title Title Title Title Title Title}
\author{AuthorName \\ Matrikelnummer: xxxxxxx}
\date{Abgabe: 25. April 2018\\ \vspace{0.9cm}}
\publishers{
  \begin{tabular}[!b]{ll}
  Erstgutachter: & Dr. Bla \\[3pt]
  Zweitgutachter: & Prof. Dr.-Ing. Blablabla \\[3pt]
  Betreuender Mitarbeiter: &  Blabla
  \end{tabular}\\[20pt]
  \centering
  \includegraphics[height=1.3\baselineskip, width=1.3\baselineskip, draft]{1.png}%
  \hspace{.333\baselineskip}
  \sffamily
  \parbox[b][1.3\baselineskip][c]{.26\paperwidth}{
      \textbf{Zentrum f\"ur\\[-0.3\baselineskip]
        Technomathematik}
  }\\[10pt]
  \includegraphics[height=1.3\baselineskip, width=1.3\baselineskip, draft]    {2.png}
  \hspace{.333\baselineskip}
  \sffamily
  \parbox[b][1.3\baselineskip][c]{.26\paperwidth}{
      \textbf{Faserinstitut\\[-0.3\baselineskip]
        Bremen}
  } \\[20pt]
\includegraphics[height=1.2\baselineskip, width=6cm, draft]{logo.png}
}

\begin{document}
\begin{titlepage}
\maketitle
\end{titlepage}

\end{document}

As you can see, I already tried to put the subject a bit higher but I really don't like the look of it. This layout is made by someone else so I don't know why I need pgfplots.

Thanks a lot for your help!

(I hope I asked in a correct way)

  • 2
    \maketitle inside a titlepage environment is just wrong. – Johannes_B Mar 28 '18 at 13:02
  • Dr. Bla and Prof. Dr. Blablabla work at every university, apparently ;-) – user31729 Mar 28 '18 at 13:11
2

As @Johannes_B mentioned in a comment \maketitle inside environment titlepage is wrong. Either you could design your title using titlepage or you can use \maketitle.

If I remove the titlepage environment and add package showframe to your example to show its page layout, I get

enter image description here

With \maketitle the class inserts vertical space below of the publishers. So you get the second page.

As a workaround for your special title page, you could use \enlargethispage:

\documentclass[a4paper,DIV=10,twoside, BCOR=1cm, fontsize=12pt,         parskip=half]{scrreprt}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[english,ngerman]{babel}
\usepackage{csquotes}
\usepackage{lmodern}
\usepackage{setspace}
\setstretch{1.2}
\usepackage{graphicx}% only graphicx is needed

\usepackage{showframe}
\subject{Masterarbeit}
\title{Title Title Title Title Title Title Title Title Title Title Title Title Title Title Title}
\author{AuthorName \\ Matrikelnummer: xxxxxxx}
\date{Abgabe: 25. April 2018\\ \vspace{0.9cm}}
\publishers{
  \begin{tabular}{ll}% remove the optional argument
  Erstgutachter: & Dr. Bla \\[3pt]
  Zweitgutachter: & Prof. Dr.-Ing. Blablabla \\[3pt]
  Betreuender Mitarbeiter: &  Blabla
  \end{tabular}\\[20pt]
  \centering
  \includegraphics[height=1.3\baselineskip, width=1.3\baselineskip, draft]{1.png}%
  \hspace{.333\baselineskip}
  \sffamily
  \parbox[b][1.3\baselineskip][c]{.26\paperwidth}{
      \textbf{Zentrum f\"ur\\[-0.3\baselineskip]
        Technomathematik}
  }\\[10pt]
  \includegraphics[height=1.3\baselineskip, width=1.3\baselineskip, draft]    {2.png}% <- % added
  \hspace{.333\baselineskip}
  \sffamily
  \parbox[b][1.3\baselineskip][c]{.26\paperwidth}{
      \textbf{Faserinstitut\\[-0.3\baselineskip]
        Bremen}
  } \\[20pt]
\includegraphics[height=1.2\baselineskip, width=6cm, draft]{logo.png}%
\enlargethispage{54pt}% <- added
}

\usepackage{showframe}% to show the page layout

\begin{document}
\maketitle
\end{document}

Result:

enter image description here

Maybe using environment titlepage with an own layout instead \maketitle would be the better decision.

  • Finally a proper answer. On a smartphone I cannot test if my comment really removes the issue and certainly cannot write a lot of text. – Johannes_B Mar 28 '18 at 15:51
  • @Johannes_B Removing environment titlepage does not solve the issue. \maketitle inserts space below publishers. Therefore the titlepage is too long for only one page. – esdd Mar 29 '18 at 6:46
  • Thanks a lot! I used \enlargethispage and \maketitle. After finishing my thesis I will have a deeper look into the environment \titlepage. – Saphira Mar 29 '18 at 8:34
1

After compiling with pdflatex, I get indeed an extra page after your title page.
I don't get that extra page after the title page when I suppress the line

\setstretch{1.2}

Playing with the vertical spaces a little bit more, it's enough to remove a few pt of added vertical space to make that extra page disappear.

So basically, the title page in your exemple code is too long to fit on one page.

But, this thesis seems intended to be printed double-sided (twoside class option). Then the title page is (usually) followed by a blank (left) page, so that the start of the report is on a right page.
You might want to use the class option "open=right" (depending on the instructions from your school, of course). Of course, you have to follow the instructions you got for preparing your thesis.

If indeed you can accept an empty page after the title page, you can suppress the page number by adding a \pagestyle{empty} just after \begin{document} and a \pagestyle{plain} just before your text. Something like:

\begin{document}
%\begin{titlepage}
%\pagestyle{empty}
\maketitle
%\end{titlepage}
%\pagestyle{plain}
\chapter*{Lorem ipsum}
0

I cannot compile your example because it uses *.png files I dont have. However, for printing a thesis, a blank page is desired behind your title page. Otherwise ink might be visible through the paper on your front page. You might even want to consider adding another blank piece of paper, i.e. a total of three blank pages in your PDF. Of course I also want to answer your question, so the answer might be the KOMA script option open=left like this

\documentclass[a4paper,DIV=10,twoside, open=left, BCOR=1cm, fontsize=12pt,parskip=half]{scrreprt}

This will however mean that all chapters open on left when printed. To change it back after the title page, please refer to the following (slightly lengthy) reply about creating a separate version for screen use.

The following is probably off-topic:

To generate a version for screen use, try changing the KOMA script options when loading scrrprt:

\documentclass[a4paper,DIV=10,**oneside**, BCOR=1cm, fontsize=12pt,parskip=half]{scrreprt}

Additionally, there is an option called open. I think the default is

open=right

which means a new chapter will always start on right (in twoside mode). It is even possible to change it on the fly using

\KOMAoptions{open=any}

For example, I used that to allow the abbreviations to start directly after the table of contents:

\frontmatter
% Title page
\input{contents/00-head/00-title-page}

% Document revision history
\cleardoublepage
\input{contents/00-head/01-header-purpose-history}

% Inhaltsverzeichnis erstellen
\KOMAoptions{open=right}
\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}
\tableofcontents

\KOMAoptions{open=any}
% Abbreviations
\input{contents/00-head/02-abbreviations}

% Lists of tables and figures
\input{contents/00-head/03-figure-table-list.tex}

\mainmatter
\KOMAoptions{open=right}
% Chapters here ---------------------------------------------------
\input{contents/01-chapters/overview}

Please note that my reply may contain mistakes, but I hope this gives you the right keywords for Google.

  • You know you could just remove the images as they have nothing to do with the problem at hand. I also think your answer doesn't really address the problem of the OP. – Johannes_B Mar 28 '18 at 13:05
  • Thanks for the input. I've tried to clarify by naming the option open at beginning of answer and marking the rest as off-topic – Jay_At_Play Mar 28 '18 at 13:08
  • And this question concerns a thesis. The formatting requirements for those can be quite bizarre (see this question – remco Mar 28 '18 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.