0

When I have the same author appearing more than once in the bibliography, the name of the author is replaced by a dash. How can I change it to always display the full name or names? I'm using BibLaTeX and Biber. I made quite a few changes to the literature style already, so could it be due to one of those changes?

Here is my minimal working example:

\documentclass[listof=totoc, 
index=totoc, 
bibliography=totoc, parskip, 
12pt, headsepline=true, a4paper]{scrartcl} 

\usepackage[ngerman, english]{babel} 
\usepackage[utf8]{inputenc} 
\usepackage[T1]{fontenc} 


%% Literaturverzeichnis
\usepackage[hidelinks]{hyperref}
\usepackage{csquotes}
\usepackage{etoolbox}
\usepackage[backend=biber, style=authoryear, maxbibnames=999, maxcitenames=2]{biblatex}
\addbibresource{Literature.bib}

% Autoren mit Slash getrennt und lastname-firstname
\renewcommand*{\multinamedelim}{\slash} \renewcommand*{\finalnamedelim}{\multinamedelim}
\DeclareNameAlias{sortname}{last-first}

% Doppelpunkt nach Jahresangabe in Klammern im Literaturverzeichnis 
\renewcommand*{\labelnamepunct}{\addcolon\addspace} 

% Titel im Literaturverzeichnis nicht kursiv 
\DeclareFieldFormat{title}{#1\isdot} 
\DeclareFieldFormat{journaltitle}{#1} 
\DeclareFieldFormat{issuetitle}{#1} 
\DeclareFieldFormat{maintitle}{#1} 
\DeclareFieldFormat{booktitle}{#1}

% Jahreszahl im Fußnotenzitat in runden Klammern 
\newbibmacro*{cite:parens:labelyear+extrayear}{% 
  \iffieldundef{labelyear} 
{} 
{\printtext[parens]{\printtext[bibhyperref]{% 
   \printfield{labelyear}% 
   \printfield{extrayear}}}}} 

\renewbibmacro*{cite}{% 
  \iffieldundef{shorthand} 
    {\ifthenelse{\ifnameundef{labelname}\OR\iffieldundef{labelyear}} 
   {\usebibmacro{cite:label}% 
    \setunit{\addspace}} 
   {\printnames{labelname}% 
    \setunit{\nameyeardelim}}% 
 \usebibmacro{cite:parens:labelyear+extrayear}} 
{\usebibmacro{cite:shorthand}}}


\begin{document}

Just some text\footcite{Test1}. And some additional text\footcite{Test2}

\clearpage 
\printbibliography

\end{document}

And my bib file looks like this:

@book{Test1,
author = {Apostolik, Richard},
title = {Test title 1},
year = {2010a}
}

@book{Test2,
author = {Apostolik, Richard},
title = {Test title 2},
year = {2010b}
}
1

BibLaTeX has a dashed option for repeated names which is true by default (with the authoryear, at least). You just have to put dashed=false in the options to biblatex:

\usepackage[dashed=false, backend=biber, style=authoryear, maxbibnames=999, maxcitenames=2]{biblatex}

Not the answer you're looking for? Browse other questions tagged or ask your own question.